Unable to change from 192.168.1.1 to 192.168.8.1 on LAN interface



  • This is an SG1100 - i tried changing my LAN from .1.1 to .8.1
    and I get the following errors:

    The following input errors were detected:

    A valid interface to track must be selected.
    

    error01.png error2.png
    I tried a few things since it does say IPV6 configuration type is the track interface. Then I tried selecting none but it says the DHCP server is active.

    Anyone can help with this? thanks.


  • LAYER 8 Global Moderator

    Your ipv6 on your lan should either be static or none. You can not track an interface that is not going to get a prefix delegation via dhcpv6. If you want to use track for yoru lan IPv6 address, then down lower in the IPv6 settings you need to select which interface to track that will get dhcpv6 with delegation, and select which subnet ID to use.

    And yeah it might tell you that dhcpd is enabled for 192.168.X when your trying to change it to 192.168.Y
    "Don't forget to adjust the DHCP Server range if needed after applying."

    So yeah your going to have to change your dhcpd range to match your new interface


  • LAYER 8 Rebel Alliance

    Disable DHCPv6 first, then set IPv6 Configuration Type to None.

    -Rico



  • @johnpoz Thank you. I will try.
    You are correct I tried to change the dhcp server range before changin the LAN ip and it indicated I could not do it before.

    Will try in a bit as I am in a video conference right now.


  • LAYER 8 Global Moderator

    keep in mind it will change the range for you auto, but if you had altered it in some way say you changed it to .100 to .200 vs the whole scope.. You might want something different after you change the network on the interface. So yeah just double check the range is what you want after you change the IP on the interface.


  • Netgate Administrator

    Yeah, the DHCPv6 server is enabled on LAN by default and it can only run on interfaces with a valid IPv6 address so the input validation will not allow you to set it to none.

    Disable the DHCPv6 server on LAN first then you can set the LAN interface to IPv6 type 'none'.

    Steve



  • @johnpoz
    Thank you. This was so obvious but because I was only looking for DHCP server V6 I did not see it listed with a slight difference as it had something else. Thanks, it worked and I am happily using my new subnet.


Log in to reply