Specific rule for gw group not taken into account



  • Hi.

    pfSense 2.4.4p2.

    I tried following several guides and everything looks ok to me, but I cannot make multi wan behave like I would.

    I have a LAN, a land ADSL and a 4G modem, connected via RJ45.

    I've created three GW groups, one for balancing and two for failover.

    efd69535-6e4c-4a47-bd32-6884108a5f3e-immagine.png

    Sticky connections
    To avoid using Sticky connections I created a LAN firewall rule to route traffic for specific sites through the ADSL priority gw group, so all connections are directed to a single line. As visible in the states below no packet is passing through it. The rule uses a firewall alias to group several hostnames, but I tried duplicating the line with a single IP address and it does the same.

    ping/traceroute to 8.8.4.4 (4G monitoring IP) goes as expected via the secondary line.

    43792c5b-a092-4745-a751-444d263239fd-immagine.png

    Balancing?
    Second issue: the balancing is not being effective, no traffic is going through the 4G network. The traffic graph shows 1kb/s, probably just the gateway monitoring packets.

    As said before I believe I'm missing something, but cannot figure out what.
    Thanks



  • Looks like the installation was broken. I had some messages of libreadline.so missing or something like that, at first was only php but then I found unbound wasn't starting because of that. Upgraded to 2.4.5 (reinstalled, to be more precise) and not the firewall rules appear to work as expected.


Log in to reply