Errors In on Lan



  • Hello
    I am having errors com in on one of my Lan Ports.
    I have Pfsense with 3 Ports, one for Wan and two for Lan so Lan1 and Lan2.
    On each on the Lans I have a Netgear D6200 router for WiFi, the routers are the same. I have had this set up for over a year with no issues.
    Recently I was given a mikrotik hap ac lite to play with. I replaced one of the Netgear router with it for about a week then switched back. Ever since the switch back there has been thousands of in errors on the Lan2 that I tried the mikrotik on. Also a dramatic speed drop on the same Lan. Lan1 is fine.
    If I plug the mikrotik back in the problem goes away, the mikrotik has 100mb ports where the Netgear has 1000mb.
    I have reset the Netgear, rolled back Pfsense to a state before I tried the mikrotik, changes cables and tried another router but still have the same issue unless the mikrotik is plugged in.
    I have check that duplex on that Lan is set to Auto.
    Does anyone have any suggestions before I reinstal Pfsense? Could it be the network card?
    Or could the mikrotik triggered a fault?

    Thanks in advance


  • Netgate Administrator

    If it's done something odd to the NIC I would first try powercycling the box entirely (actually remove the power cable for 30s) if you have not already.
    I note that device is also PoE capable and looks like it's maybe not true 802at? Was it coinfigured for that and toasted the NIC somehow?

    Steve



  • @stephenw10 thanks for the reply, I have rebooted but not disconnected the power supply so will try that.
    Yes the mikrotik has POE on one port but I didn't use that port.
    I will try the power cycle and see what happens.
    Could one of the ports get fried and not the other one on a card?


  • Netgate Administrator

    Yes, that's entirely possible.

    Try re-assigning two interfaces, swap ports. Do the errors follow the AP or stay on the port?

    Steve



  • @stephenw10 I have re-assigned the interfaces and swapped ports and AP's only the issue on the one nic so that seems to be the fault. Must of failed somehow.
    Thanks for your help and suggestions



  • @rybena, I think your nic become lazy ;) Do you have any network switch with an uplink function?
    If so try this, turn on uplink function on your switch, use a shorter lan cable. Connect this cable to the lazy nic, then go to Interfaces > Lan (lazy nic) > Unchecked Enable interface > save > then re-enable lan interface > save > apply changes.


Log in to reply