firmware upgrade seems to have bricked the unit - how do we fix this?



  • Hi all,

    We just tried setting up my new - netgate SG-1100 with pfsense

    • We got the basics setup ok

    • Then my friend installed the software firmware update

    • as the update was finishing - it said wait while it reboots (or something like that) - then kept recycling over and over - never finishing

    • after that it seemed to brick the unit - and said that certain things could not be found - related to PHP etc.

    q: So now what? How Do we get this working?

    q: Since it is new do I create a ticket or something?


  • LAYER 8 Rebel Alliance

    Open a ticket with Netgate: https://go.netgate.com
    They will provide you the original pfSense Image for the SG-1100

    -Rico



  • Something is definitely screwy with the upgrade. I semibricked my netgate box last week bringing it up to date.. I still have console and was able to start sshd from that so it's 'up' in some definitions of 'up' but it is a sick puppy. I've tried a pkg upgrade but there seems to still be a lot of stuff missing.


  • LAYER 8 Global Moderator

    Yeah if you open a ticket, they will be sure to help you very quickly with factory version.

    Out of curiosity, since this is new unit - what version did it come with 2.4.5p1 has been out for a while. I would think it would of come with that already installed?

    I take it was something earlier? And you were going to 2.4.5p1, or where you trying to put on 2.5beta?



  • my issue seems to be that for some reason something still wants the old php stuff which has been zapped.
    I'd load a new one but don't know how to get it,.
    lots of message like;
    Warning: PHP Startup: Unable to load dynamic library 'zlib.so' (tried: /usr/local/lib/php/20131226/zlib.so (/usr/local/lib/php/20131226/zlib.so: invalid file format), /usr/local/lib/php/20131226/zlib.so.so (/usr/local/lib/php/20131226/zlib.so.so: invalid file format)) in Unknown on line 0

    note old version....

    and in the old version directory all the files are now 0 bytes long.
    I suspect it ran out of space at one stage of the upgrade.
    I'd load new (old) copies but don't know where to find that old version of php pkg.


Log in to reply