upgrade to 2.4.5 gone bad.. php libs gone missing.


  • I tried upgrading it never made it all the way back up after the reboot..
    lots of
    Warning: PHP Startup: Unable to load dynamic library 'zlib.so' (tried: /usr/local/lib/php/20131226/zlib.so (/usr/local/lib/php/20131226/zlib.so: invalid file format), /usr/local/lib/php/20131226/zlib.so.so (/usr/local/lib/php/20131226/zlib.so.so: invalid file format)) in Unknown on line 0

    messages..
    the old version seems to have been wiped out....
    [2.4.5-RELEASE][admin@]/conf: ls -la /usr/local/lib/php/20131226/
    total 156
    drwxr-xr-x 2 root wheel 1536 Oct 9 11:01 .
    drwxr-xr-x 5 root wheel 512 Oct 1 05:30 ..
    -rw------- 1 root wheel 0 Oct 1 06:08 bcmath.so
    -rw------- 1 root wheel 0 Oct 1 06:08 bcmath.so.so
    -rw------- 1 root wheel 0 Oct 1 06:08 curl.so
    -rw------- 1 root wheel 0 Oct 1 06:08 curl.so.so
    -rw------- 1 root wheel 0 Oct 1 06:08 dom.so
    -rw------- 1 root wheel 0 Oct 1 06:08 dom.so.so
    [etc].

    I did a pkg upgrade which seems to have helped a bit.. ad then ran pfSense-upgrade
    which spewed out more php errors
    but did some stuff with pkg.
    Then I ran pkg -d which replaced a lot of stuff.
    so the system seems a bit healthier now
    but I don't know what still needs the old version of php.. and where I can get a new copy of the old version.

    It'd be nice if pkg had a 'reinstall all installed packages' option...

  • LAYER 8 Rebel Alliance

    I‘d just reinstall the system and restore the config.

    -Rico


  • @Rico I'm remote from the system. I don't have the luxury of that as far as I know....If it was just FreeBSD I'd be fine as I know all the moving pieces but all the php and database stuff to me is a mystery. So I don't know if I could reinstall while running it... If it used Boot environments it would be easier to experiment..
    Maybe I can just get a copy of php/20131226/ from someone..

  • LAYER 8


  • thing is that I think the upgrade is only half done.
    there are still pfsense binaries trying to access the old libraries. pfSense-upgrade is one of them..I need to get a new copy of these old binaries.
    I'm trying the 'reinstall every pkg ' option in the page you pointed to.. if that doesn't help it's going to be a difficult time bootstrapping this thing up.


  • well that was a bust the install scripts for the new stuff want to run the old stuff???

    pages and pages of:

    Warning: Invalid argument supplied for foreach() in PEAR/Command.php on line 249
    XML Extension not found
    pkg-static: POST-INSTALL script failed
    [52/174] Reinstalling php72-pear-HTTP_Request2-2.3.0,1...
    [52/174] Extracting php72-pear-HTTP_Request2-2.3.0,1: 100%

    Warning: Failed loading Zend extension 'opcache.so' (tried: /usr/local/lib/php/20131226/opcache.so (Cannot open "/usr/local/lib/php/20131226/opcache.so"), /usr/local/lib/php/20131226/opcache.so.so (/usr/local/lib/php/20131226/opcache.so.so: invalid file format)) in Unknown on line 0

    Warning: PHP Startup: Unable to load dynamic library 'pfSense.so' (tried: /usr/local/lib/php/20131226/pfSense.so (Cannot open "/usr/local/lib/php/20131226/pfSense.so"), /usr/local/lib/php/20131226/pfSense.so.so (/usr/local/lib/php/20131226/pfSense.so.so: invalid file format)) in Unknown on line 0

  • LAYER 8

    pkg-static clean -ay; pkg-static install -fy pkg pfSense-repo pfSense-upgrade
    

    ??


  • yeah did that before..


  • managed to get the system up but option 12 on the menu is still spewing errors. The library file suhosin.so is in the 20131226 directory. Everything else in there is 0 bytes long so I moved it to one side. If I put just the suhosin .so file there it just makes it so much worse because it then looks for a whole bunch more but cant find them (or they are 0 bytes if it can).. Since the new release uses 20170718, what is still looking for the old php?

    
    Warning: PHP Startup: Unable to load dynamic library 'suhosin.so' (tried: /usr/local/lib/php/20170718/suhosin.so (/usr/local/lib/php/20170718/suhosin.so: invalid file format), /usr/local/lib/php/20170718/suhosin.so.so (/usr/local/lib/php/20170718/suhosin.so.so: invalid file format)) in Unknown on line 0
    Netgate SG-4860 - Serial: 1507152081 - Netgate Device ID: 804bab56f8c31a1b414b
    
    *** Welcome to pfSense 2.4.5-RELEASE-p1 (amd64) on pfSense ***
    
     WAN0 (wan)      -> igb0       -> v4/DHCP4: 192.168.0.27/24
     LAN2 (lan)      -> igb1       -> v4: 192.168.2.2/24
     WIFIQBURNETTIA (opt1) -> ath0_wlan0 -> v4: 192.168.3.1/24
     LAN4 (opt2)     -> igb2       -> v4: 192.168.4.1/24
    
     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12) PHP shell +
    Warning: PHP Startup: Unable to load dynamic library 'suhosin.so' (tried: /usr/local/lib/php/20170718/suhosin.so (/usr/local/lib/php/20170718/suhosin.so: invalid file format), /usr/local/lib/php/20170718/suhosin.so.so (/usr/local/lib/php/20170718/suhosin.so.so: invalid file format)) in Unknown on line 0
    pfSense tools
     4) Reset to factory defaults         13) Update from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM```

  • The suhosin lib is not compatible with PHP 7.2.
    You have to delete the following file: "/usr/local/etc/php/ext-30-suhosin.ini" to disable this PHP extension.