fq_codel Traffic Shaping with WiFi



  • I've played around with fq_codel limiter and got it working pretty good over my wired connection. I'm consistently getting an "A" for bufferbloat on speedtest pages.

    I'm wondering how do I handle bufferbloat over wifi. Over wireless, I get a "D" or an "F" for my bufferbloat score. My ISP connection is 350/25, I have the limiter set to 348/23, and the wired connection gets about 280/20. On my wireless connection, I'm seeing about 140/18 with that "F" for a bufferbloat score.

    I'm guessing it's because the wifi isn't as fast as the wired and it's not hitting the limiter. I'm also going to guess that to fix it, I could set the limiter to 100Mbps.

    Is this the correct thing to do? How do other people handle wireless?

    Thanks!



  • This depends on your wifi setup. Hopefully pfSense is not running a wifi NIC, and you've got a dedicated access point.

    Most of the decent access points will do enough QoS/prioritization on their own that you can get a decent score.

    But the biggest issue with wifi is the limited CPU of most cell phones/tablets. If you're running a speedtest, this usually hammers the CPU and causes a lot of the latency in the test to be a lack of response from the tablet or phone due to the CPU being maxed out for the duration of the transfer test.

    I would not lower the QoS limit because then multiple devices on your network will all bottleneck at that imposed limit. I have my FQ Codel limit set at the highest wired-speed that my internet connection can sustain and still get consistent A scores on buffer bloat tests. I don't worry about wifi due to the varying nature of the devices that will be on the AP (anywhere from lower powered 1x1 antenna phones to modern laptops with 2x2 or 3x3 antennas).



  • @pfsvrb said in fq_codel Traffic Shaping with WiFi:

    I would not lower the QoS limit because then multiple devices on your network will all bottleneck at that imposed limit. I have my FQ Codel limit set at the highest wired-speed that my internet connection can sustain and still get consistent A scores on buffer bloat tests. I don't worry about wifi due to the varying nature of the devices that will be on the AP (anywhere from lower powered 1x1 antenna phones to modern laptops with 2x2 or 3x3 antennas).

    Thanks for the information. I'll leave that set to where it's at.

    I do agree with maybe looking into seeing if my AP could do limiting or QoS too. Unfortunately, there are a lot of variables in wifi that would make doing limiting/QoS on it difficult.

    I'll have to see what can be done, if any, with it. I have a Ubiquiti AP and I know there's QoS settings if you use their gateway but I'm not sure about just a regular AP.



  • For others that are in a similar situation...

    Turns out that with the Unifi Controller, you can change the default "User Group" to set a speed limit. Since over Wifi, I'm seeing 120/20, I set my limit to 100/20. When doing the speedtest, I'm now not seeing any bufferbloat and I'm getting an A+ from an F before, but I'm getting speeds around 80/20.

    Just a tip too. For reasons unknown, in my controller, I had to specify Kbps and couldn't set it to anything over 100Mbps. I was getting some sort of weird payload error. Some say it was a bug but who knows.

    For now, I'll keep it as it is and see how it works. Hopefully it will have a positive effect on zoom meetings.


Log in to reply