NAT FTP Rule Doesn't Work



  • I searched the forums and followed all the directions I saw. Still can't get this to work. I have an vsftp server on Fedora Core 4 that I want to expose to the internet. I created the NAT rule, made sure the auto create firewall rules box was checked. It created the 2 firewall rules. I then on the WAN page unchecked disable ftp proxy and unchcked block private networks. Still doesn't work the connections is accepted and then dropped. In the error log I get

    pftpx event_dispatch error: Operation not supported by device.

    The kicker is in the mist of playing with the settings pfsense will either drop the WAN connection or reset by itself. This has happened twice now. Pfsense is running on an nokia ip330 box with 128mb ram. This box has been stable for over 30 days no restarts or errors until I played with FTP settings. Once I put it back to the way it was its stable again. Forgot to mention this is version RC1a.

    Heres the thread I followed. I searched and didn't realize it was just a few posts below or I would've posted in it.

    http://forum.pfsense.org/index.php/topic,1471.0.html

    Also this thread. I'm having the same error as shawnspeak

    http://forum.pfsense.org/index.php/topic,771.15.html

    My rules that were automatically created were just like his. One had a blank destination. Didn't work like that and then I tried changing it to any and it didn't work that way either. Some insight here would be appreciated.



  • So nobody has any ideas what that error means or how to fix it. I'm sure thats the underlying problem of why the FTP NAT doesn't work. This is an ip330 box with 3 intel nics so I don't see why how the nics could be unsupported.

    I searched on google and can't find what to do for this error. It doesn't even show up on google.



  • Try to play around with the ftp options at system>advanced and see if that makes a difference.



  • Finally got some time to play with the settings again as this is on a production box. I tried changing the use device polling settings but that didn't help and most the other settings didn't seem to apply. I'm not sure what the problem is. I really would like to know what the above error means and how to resolve that.


Locked