Freeswitch errors



  • Hello -

    We are running pfsense 1.2.2  and have had the freeswitch package loaded on the firewall for some time now. At first it worked, but after an upgrade some time ago, it is busted. When I go to the status tab, I get a whole screen full of messages like:

    Warning: fsockopen(): unable to connect to (my outside ip):8021 in /usr/local/pkg/freeswitch.inc on line 163 Warning: socket_set_blocking(): supplied argument is not a valid stream resource in /usr/local/pkg/freeswitch.inc on line 164 Warning: fsockopen(): unable to connect to 192.168.1.1:8021 in /usr/local/pkg/freeswitch.inc on line 163 Warning: socket_set_blocking(): supplied argument is not a valid stream resource in /usr/local/pkg/freeswitch.inc on line 164 no handle
    
    

    Does the package run on 1.2.2? if so, what do I need to do to fix this?

    Also - seems to me that this package deserves it's own section on the forum now.

    Thanks for all you fine work -

    Library Mark



  • I built the pfSense FreeSWITCH package for 1.2.3 and higher. FreeSWITCH was compiled for FreeBSD 7.x. Also it is important may useful to mention that pfSense 1.2.3 latest snapshots have a UDP connection adjustment that helps maintain UDP connections when using System -> Advanced -> Firewall Optimization -> conservative.



  • Thanks, man - that helps. You are doing fantastic work!



  • @mcrane:

    I built the pfSense FreeSWITCH package for 1.2.3 and higher. FreeSWITCH was compiled for FreeBSD 7.x. Also it is important may useful to mention that pfSense 1.2.3 latest snapshots have a UDP connection adjustment that helps maintain UDP connections when using System -> Advanced -> Firewall Optimization -> conservative.

    Hi,

    I just did a complete re-install of FreeSWITCH, uninstalled it and then removed everything in xml and restored system from that xml and after reinstall of FreeSWITCH and system restart I did not see any old stuff in FreeSWITCH config. So added everything again.

    Added 1 extension and one gateway. Didn't touch any xml.
    I couldn't get it to start, in fact I got the kind of errors as mentioned here: http://forum.pfsense.org/index.php/topic,16413.msg87949/topicseen.html#msg87949 by "professorpaw".

    Then I saw this thread again. I am running 1.2.2.

    Should I simply assume that I will not get FreeSWITCH running on 1.2.2 and wait for next version, or try RC1 instead?

    TIA,



  • I had the same thing happen, and when I updated to 1.2.3-RC1, freewswitch took right off and is running fine.


Log in to reply