HELP!!! Load balancing won't use both connections



  • HELP, i have 2 wans but i cant get Load balancing to use SSH just over WAN2 and others just over WAN1, it either uses WAN1 or WAN2 but never WAN1+2 same time

    IFs:

    WAN interface (rl1)
    Status up
    DHCP up   
    MAC address 00:50:fc:40:be:71
    IP address 172.16.14.69 
    Subnet mask 255.255.254.0
    Gateway 172.16.14.1
    ISP DNS servers 195.58.160.194
    195.58.161.122
    Media 100baseTX <full-duplex>In/out packets 52920/67731 (19.76 MB/76.65 MB)
    In/out errors 0/0
    Collisions 0

    LAN interface (fxp0)
    Status up
    MAC address 00:30:05:1a:34:1c
    IP address 11.1.1.1 
    Subnet mask 255.255.255.0
    Media 100baseTX <full-duplex>In/out packets 58686/39450 (76.30 MB/8.37 MB)
    In/out errors 0/0
    Collisions 0

    WAN2interface (rl0)
    Status up
    MAC address 00:11:2f:5f:39:84
    IP address 10.250.0.151 
    Subnet mask 255.255.0.0
    Gateway 10.250.0.3
    Media 100baseTX <full-duplex>In/out packets 3406/598 (629 KB/71 KB)
    In/out errors 0/0
    Collisions 0

    LB:
    –----------

    Name Type Servers/Gateways Port Monitor Description

    Wan1BalanceWan2 gateway
    (balance) wan
    opt1 172.16.14.1
    10.250.0.3 Wan1BalanceWan2

    Wan1FailoverWan2 gateway
    (failover) wan
    opt1 172.16.14.1
    10.250.0.3 Wan1FailoverWan2

    Wan2FailoverWan1 gateway
    (failover) opt1
    wan 10.250.0.3
    172.16.14.1 Wan2FailoverWan1

    PLEAS HELP,

    WAN2 has just ports 22 and 80 open so i cant even read my mails when it runs over WAN2, i just cant get it to use SSH over WAN2 but mail over WAN1

    Plz tell me what i did wrong




    </full-duplex></full-duplex></full-duplex>



  • @Almo:

    HELP, i have 2 wans but i cant get Load balancing to use SSH just over WAN2 and others just over WAN1, it either uses WAN1 or WAN2 but never WAN1+2 same time

    Yes this is how the loadbalancer works.
    It is connection based and doesnt sum up the total bandwidth you have.

    Or do you mean you want to implement policy routing for SSH to ALWAYS go over WAN2?
    In this case: you've set the "source-port" to 22. Set it to "any" since the source of a connection is random.



  • So i cant use 2 connections the same time?

    Like route based load balancing?

    Like port x wan1
    port y wan2??

    If this doesnt work its useless isnt it?



  • You mean policy routing.

    Load balancing is to balance connections over multiple wans.
    Forcing a connection to a gateway doesnt involve balancing ;)



  • ok so i think thats what i want, can u help me with that?

    I thought i did that didnt i?



  • Please reread my first response.
    I edited it while you already wrote your next post :D

    I should be as simple as setting the source-port to "any"



  • Hi  GruensFroeschli

    Actually im having the proplem that as soon as WAN2 goes to "ONLINE" ALL connections goes over WAN2, i dont understand this, i cant even force connections to go over WAN1 as soon as WAN2 is online.

    And to answere your qestion, yes i want SSH always to go over WAN2 but all other connections to use WAN1

    Also WAN2 sometiles just suddenly goes OFLLINE with no real reason   could snort block it or so?

    Another Proplem that occures is this:

    ping 10.250.0.3

    PING 10.250.0.3 (10.250.0.3): 56 data bytes
    ping: sendto: Operation not permitted

    This is really a PIA atm  ;)



  • ATM it looks good, it still uses WAN2 as default instad of WAN1 but thakns your tips i can now atleast force my mails to use WAN1

    But i stiull have no glue why WAN2 sometimes drops


Log in to reply