• Hello all,

    I am running pfSense latest version on a Lenovo SFF PC in the living room with a quad port intel NIC. It's been running well for several months, now all of a sudden we are experiencing lots of trouble.

    I will be doing stuff on the network, and all of a sudden I have lost connection. Usually when this happens, I cannot ping the gateway from OPT1 or LAN network until I hot-plug.

    The system log gives me no information about what happened, or why it has stopped working. I have had this happen quite often over the last few days and I have had enough. I lose internet connection on the LAN networks and sometimes even the WAN will act up until I hot-plug it. This usually requires me to reset my modem to re-lease the IP address from my ISP.

    I am wondering if this could be an issue with the drivers, or something to do with the card and going to sleep? What information do you need to help me look into this problem, and where is the best place to find information on these problems.

  • Netgate Administrator

    If it actually loses connection I'd be amazed if nothing is logged at all, in any log.

    Does it show the WAN gateway go down?

    Steve


  • @stephenw10 The only thing on the WAN gateway I see is this:

    send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 1 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 8.8.8.8 bind_addr 174.109.12.*** identifier "WAN_DHCP "
    

    every once in awhile. This actually happened after I began the hot plug of the other LAN ethernet cables.

    I shouldn't be losing access to the router even if the WAN is down though, right? I lose all access to the router, but I can still ping some other devices in the subnet. I cant figure anything but power saving issues or else the card may be going bad... but all 4 ports at once?!

  • Netgate Administrator

    That log entry is dpinger, the gateway monitoring service, starting. You would normally expect to see that when the WAN is connected or the WAN settings are re-saved etc.
    It is not an alarm log showing it went down.

    If you connect to the pfSense console can you ping out from there when this happens?

    If you run 'ifconfig -a' do the interfaces still show as up and linked?

    There may be an error shown at the console which isn't logged.

    Steve


  • @stephenw10 I haven't tried from the console because I couldn't SSH into it. Next time this happens I will try to hookup a monitor and do it from the console. When I do the hot-plug of the OPT1 network it shows up in the log as unplugged, and re-enabled. There weren't any information or logs before then though to state it was down; that is what I am confused by.

  • Netgate Administrator

    Can we see the actual logs shown?


  • @stephenw10 The issue kind of resolved for a little while, or I haven't noticed it. Then yesterday while I am at work my wife began complaining again. This time when I got home I realized the issue was only on one LAN port.

    My upstairs is where I run the small "lab" and the OPT1 port first goes into a PowerConnect 2284 managed switch; that switch is LAG'd to a PowerConnect 5548p for POE devices. My desktop was hooked up to the PowerConnect 2284 and I was able to connect to the switch still, but could NOT ping the pfSense router.

    I had to reboot the switch, or unplug and replug the cable for that interface in order for the router to be accessible again. The other LAN port was still working fine.

    Going to look into getting the logs and removing any information I need to, stand-by.