OpenVPN Client configuration



  • Hello,

    Using RC1, I'm configuring an OpenVPN cliient to connect to an existing, linux based,  OpenVPN server.
    The configuration uses the TCP protocol, the connection to the server via http proxy and PKI for authentication.
    Also, the Interface IP field, setting the IP to be assigned to the local interface, is left blank, as the remote OpenVPN server would dynamically set it, likewise my other  working clients (not pfSense based).

    As  mentioned above, such  client configuration uses the http proxy to contact the remote server. However, when the relevant fields for the proxy server and the proxy port are filled I experience the following problems:

    1. the configuration is not saved and pfSense complains that a TCP based vpn connection is needed for the configuration using http proxy, although the protocol field is actually set to TCP.

    2. Since the http proxy needs authentication (BASIC), I can't find in the gui the fields for username and password to enter.  Should I enter them in some file manually, like the standard openVPN implementation would require?

    Thank you and best regards.



  • @mazott:

    Hello,

    Using RC1, I'm configuring an OpenVPN cliient to connect to an existing, linux based,  OpenVPN server.
    The configuration uses the TCP protocol, the connection to the server via http proxy and PKI for authentication.
    Also, the Interface IP field, setting the IP to be assigned to the local interface, is left blank, as the remote OpenVPN server would dynamically set it, likewise my other  working clients (not pfSense based).

    As  mentioned above, such  client configuration uses the http proxy to contact the remote server. However, when the relevant fields for the proxy server and the proxy port are filled I experience the following problems:

    1. the configuration is not saved and pfSense complains that a TCP based vpn connection is needed for the configuration using http proxy, although the protocol field is actually set to TCP.

    Try a recent snapshot, I believe I fixed that bug after RC1.

    @mazott:

    1. Since the http proxy needs authentication (BASIC), I can't find in the gui the fields for username and password to enter.  Should I enter them in some file manually, like the standard openVPN implementation would require?

    Enter them in the "custom options" box at the bottom (yeah, I know it's small, that's fixed in the HEAD trunk, sorry) just as if you were adding to the normal config file.

    –Bill


Locked