DS-Lite pfSense Disconnect


  • Hallo,
    ich bin Kunde bei M-net und habe versucht mein Internet (ds-lite) über pfSense zum laufen zu bringen, dafür bin ich folgender Anleitung gefolgt:

    https://cybercyber.org/m-net-ds-lite-anschluss-mit-pfsense.html

    Mir ist nur nicht klar, was mit dem letzten Schritt gemeint ist: "Dann konnte ich das Gateway der Verbindung (192.0.0.1) als default-Gateway eintragen und hatte sofort V4-Internet".

    Was ich gemacht habe: Ich habe das Gif Interface als neues Interface assigned und hatte dann ein neues Interface mit dem Namen: OPT1. Dieses habe ich aktiviert und hatte dann auch sofort Internet, soweit so gut. Sobald ich jedoch einmal die WAN-Verbindung getrennt habe (z.B. durch Neustart) konnte ich keine Verbindung mehr herstellen, selbst, wenn ich das OP1-interface und das GIF-Interface gelöscht habe. Das einzige, was geholfen hat, war pfSense auf Werkseinstellungen zurücksetzen und dann wieder alles neu konfigurieren.

    Ich bin über jede Hilfe dankbar und würde nach erfolgreicher Einrichtung auch eine Anleitung für andere Nutzer schreiben.

    Grüße,
    Jonas

  • LAYER 8 Moderator

    @ashold7 Hallo Jonas,

    du hast also auch ein Modem am Start? Oder wie läuft die Verbindung ab?

    Hast du nach der Verbindungstrennung denn noch IPv6 wenigstens? Oder liegt da auch keine Verbindung mehr an? Dann käme das Problem daher, nicht vom GIF Interface.

    Ansonsten wäre im Falle dass es nicht (mehr) läuft bevor du einen kompletten Reset machst interessant ob nach Rückbau (also löschen des GIF Interface, so dass nur noch der v6 Part aktiv ist) dann das hier funktioniert:

    ifconfig gif0 create
    ifconfig gif0 inet6 tunnel <<LOCAL IPv6 ADDRESS>> <<AFTR ADDRESS>> 
    mtu 1460 -accept_rtadv ifdisabled
    ifconfig gif0 inet 192.0.0.2 192.0.0.1 netmask 255.255.255.248
    route add default -interface gif0
    

    also das manuelle erstellen des GIF Tunnels mit Setzen auf aktiv bekommener IPv6 (auf dem LAN wenn ich das recht verstehe weil das WAN wohl keine public bekommt?) und die AFTR Adresse von M-Net.


  • @jegr Hallo,
    vielen Dank für deine ausführliche Antwort. Ich benutze das Vigor 130 als Modem und dieses hängt in der aktuellen Kofiguration noch vor der Fritzbox und das läuft einwandfrei, also sollte dies nicht das Problem sein.

    Ich habe das heute versucht: Als erstes habe ich das so alles eingerichtet, dass ich Internet habe, dann habe ich das OPT1 Interface und das GIF Interface gelöscht. Ich hatte erstmal trotzdem weiterhin Internet, weil das GIF Interface, soweit ich es verstehe ja nur einmal gebraucht wird, um eine ipv4 zu ziehen. Dann habe ich das WAN disconnected und wieder neu verbunden. Ich hatte kein Internet mehr auch nicht ipv6. Ich habe sogar explizit 2a00:1450:4001:81f::2003 (google) angepingt, um DNS-Probleme zu umgehen, sollte es diese geben. Ich habe aber auch dort nur einen Timeout bekommen.

    Ich weiß nicht, ob das was damit zu tun hat, aber, ich habe ja bei dem WAN - Interface, welches über DHCPv6 konfiguriert ist, eingestellt "Request a IPv6 prefix/information through the IPv4 connectivity link". Deswegen frage ich mich, ob man nicht sogar das GIF-Interface braucht, um eine IPv6 Internetverbindung aufzubauen, aber der Tutorialschreiber soll ja trotzdem schon IPv6 Internet, ohne das GIF-Interface gehabt haben?

    Grüße,
    Jonas

  • LAYER 8 Moderator

    @ashold7 said in DS-Lite pfSense Disconnect:

    vielen Dank für deine ausführliche Antwort. Ich benutze das Vigor 130 als Modem und dieses hängt in der aktuellen Kofiguration noch vor der Fritzbox und das läuft einwandfrei, also sollte dies nicht das Problem sein.

    Darf ich doof fragen warum? Wenn du doch ein Modem hast, warum dann umständlich die Verbindung über die Fritzbox aufbauen lassen (die ja eigentlich selbst ein Modem hat - warum soll diese dann ein externes nutzen?) und nicht direkt über die pfSense? Ist mir jetzt im ersten Moment nicht ganz klar, aber vielleicht überlese ich auch was? :)

    @ashold7 said in DS-Lite pfSense Disconnect:

    Ich weiß nicht, ob das was damit zu tun hat, aber, ich habe ja bei dem WAN - Interface, welches über DHCPv6 konfiguriert ist, eingestellt "Request a IPv6 prefix/information through the IPv4 connectivity link". Deswegen frage ich mich, ob man nicht sogar das GIF-Interface braucht, um eine IPv6 Internetverbindung aufzubauen, aber der Tutorialschreiber soll ja trotzdem schon IPv6 Internet, ohne das GIF-Interface gehabt haben?

    Genau das macht mich an der Geschichte ebenfalls stutzig. Denn DSlite bezieht ja gerade nicht die IP via v4 sondern umgekehrt. Ich würde daher den Haken mit v6 via v4 beziehen mal rausnehmen und versuchen, ob/dass du soweit kommst, dass du zumindest auf IPv6 Level ein sauberes "UP" hinbekommst und zumindest weiter als einen Hop weit mit v6 pingen kannst. Das wäre dann schonmal ein Erfolg. Dann könnte man immer noch sehen, wie man danach die v4 draufgemogelt bekommt :)

    Grüße