Lightsquid Report // Squid - Not Working



  • I installed squid. set it up and enabled logging. its in transparent mode. I installed lightsquid. I just cant get it to show any data.

    Squid seems to be working fine I can see lots of data in the access file. But lightsquid is not showing anything.

    Sorry if this has been addressed before, I just cant find a post to solve this problem.

    EDIT: Ok If i use port 3128 in browser it logs the data. but when I put squid back in transparent mode it doesn't log. Also, when i blacklist a site it is still showing up.

    So obviously it's squid thats not working. why is squid being bypassed?



  • ok. turn on your transparent mode then save. and to make sure its save? take a loot at your /usr/local/etc/squid/squid.conf it should be written there… 80 transparent. if this is correct then. run pfctl -sn you should see the most important to make squid transparent.
    rdr on em0 inet proto tcp from any to ! (em0) port = http -> 127.0.0.1 port 80
    if its not there then your squid.inc might be altered. try reinstall the package.



  • I am having a bit of trouble understanding what you are saying. From what I gather you are saying it is important for the packet filter to be redirecting to localhost on port 80 to use the proxy.

    I currently have the firewall disabled. Is this preventing the redirection?

    The reason it is disabled: I turned off NAT and create a LAN and WAN rule to allow ALL, but for some reason LAN clients can't Authenticate with the WAN RADIUS server. They can ping the RADIUS, access the RADIUS server's HTML pages, but when they try to radius auth, it doesn't allow the packets through.

    I am very inexperienced with linux/freebsd. Thank you for your help.



  • cant redirect if firewall is disabled. since pf is the firewall.


Log in to reply