• I've got a strange issue that's popped up in the last few weeks. In short, i'm now getting the following error message when I go to the pfsense console in alerts:

    Filter Reload
    There were error(s) loading the rules: /tmp/rules.debug:73: errors in queue definition - The line in question reads [73]: queue qLink on igb1 priority 2 qlimit 500 priq ( default )
    @ 2021-01-12 00:17:07
    There were error(s) loading the rules: /tmp/rules.debug:73: errors in queue definition - The line in question reads [73]: queue qLink on igb1 priority 2 qlimit 500 priq ( default )
    @ 2021-01-12 00:17:08
    There were error(s) loading the rules: /tmp/rules.debug:73: errors in queue definition - The line in question reads [73]: queue qLink on igb1 priority 2 qlimit 500 priq ( default )
    @ 2021-01-12 00:17:12
    There were error(s) loading the rules: /tmp/rules.debug:73: errors in queue definition - The line in question reads [73]: queue qLink on igb1 priority 2 qlimit 500 priq ( default )
    @ 2021-01-12 00:17:13
    

    The actual line in question is
    queue qLink on igb1 priority 2 qlimit 500 priq ( default )

    in this block

    altq on igb0 codelq bandwidth 49Mb queue 
     altq on igb1 priq queue {  qLink,  qACK  } 
     queue qLink on igb1 priority 2 qlimit 500 priq (  default  )  
     queue qACK on igb1 priority 6 
    code_text
    

    I create this config using the Wizard using the following steps. The intent is really just to avoid hitting my upload limit (50mbps) which is heavily policed by our local monopoly wholesale provider. If you hit the limit, they drop packets, so it really hurts upload speed.

    • Firewall -> Traffic Shaper
    • Click on Wizards
    • Click on dedicated links
    • Accept the default value of 1
    • In the upload,one mbp below your plan (49).
    • In the download, put in the full speed of your download speed. (930)
    • Change nothing else
    • Next / Next Next leaving everything default
    • Click on Finalise.
    • Allow that script to run.
    • Go to Firewall -> Traffic Shaper
    • Select WAN and change scheduler type to CODELQ
    • Ensure the bandwidth is marked at your desired speed (1 mbp below your upload plan speed)
    • Click on save and then apply
    • Click on LAN, qlink. Deselect "Explicit Network Congestion" and ensure only default queue is selected. Leave everything else as is. Click on save and then apply.
    • Click on LAN, qACK. Ensure none of the boxes are ticked under scheduler options (you may have to untick one or two of them). Click on save and then apply.

    I've been running this config for ages without issue, but in recent weeks i have been getting this error. Everything seems to work fine, but it's an annoyance.

    I've deleted and re-created the config via the wizard, and it appears to work for some time afterwards without issue and then at some point after starts producing these alerts again.