Em dirver v6.0.5



  • I run PFsense HEAD for testing purpose.
    I just added a "Intel® PRO/1000 PT Desktop Adapter" to that testing machine.
    A few weeks ago I tested the em  driver on FreeBSD on that card and it works fine.
    I was excited to see it being added to pfsense so I updated pfsense to HEAD.
    Anyway my card doesnt get detected, is there something I need to do? like load the driver or anything  ?
    Oh and btw maybe it is normal but the if_em.ko is not available in /boot/kernel. Or is the driver just build into the monolithic kernel ?

    What can I do to get it to work? or is it just a bug ?

    Thanks
    Ponl



  • Patience, it will be available soon and show up in a pfSense near you ;)



  • sorry, I didn't know it took time till it syncs.
    Thanks for the quick reply ;)

    Ponl



  • @Ponl:

    sorry, I didn't know it took time till it syncs.
    Thanks for the quick reply ;)

    Ponl

    This driver hasn't yet been brought into FreeBSD.  However, I brought it into our tree per the bounty http://forum.pfsense.org/index.php/topic,1726.msg9987.html#msg9987 on it (but haven't yet heard back from the requestor if he can test it - let alone if the bounty is valid).  Before this can reach RELENG_1 it needs to be tested, we're planning on testing that it hasn't broken anything on our hardware.  However, we'll need someone to test a snapshot release and confirm it fixes the issue on this hardware.  Will you be able to do that if we provide an image?

    –Bill



  • This driver hasn't yet been brought into FreeBSD.

    Actualy this driver v6.0.5 is already in FreeBSD; although only in current.

    Yes, if you give me instructions on how to test it and where I can get it I will.

    Regards
    Ponl



  • @Ponl:

    This driver hasn't yet been brought into FreeBSD.

    Actualy this driver v6.0.5 is already in FreeBSD; although only in current.

    Yes, if you give me instructions on how to test it and where I can get it I will.

    Regards
    Ponl

    NO, actually, it's not.

    char em_driver_version[] = "Version - 5.1.5";

    That's in sys/dev/em/if_em.c,v 1.122.  Your card may work in FreeBSD-7, but that driver is NOT Intel version 6.0.5.  We'll have a test version with the new intel driver after RC2 goes out the door.  Thanks

    –Bill



  • Thanks for pointing that out to me Bill, Let me know when you got that snapshot ready ;)
    EDIT : I tested the snapshot and the driver seems to work good !
    Regards
    Ponl


Locked