Another problem - PPPoE



  • After fixing bug which prevented loading configuration I have found this one with PPPoE - PPPoE starts and die. Here is log print screen.

    Sasa





  • @nocer:

    http://forum.pfsense.org/index.php/topic,17265.msg89839.html#msg89839

    TNX!

    My mistake. I didn't read recent posts. My only wish was to try vouchers on captive
    portal.

    Sasa



  • Hi,

    never mind, I too still have same/various issues but hey, it's only -AA. Also this seems to be fixed in 8.0-based build but sshd won't start instead.

    cheers,



  • @nocer:

    Hi,
    never mind, I too still have same/various issues but hey, it's only -AA. Also this seems to be fixed in 8.0-based build but sshd won't start instead.
    cheers,

    It looks to me that this is general mppd problem in 7.2 - not pfS bug.



  • Its a missing kernel option.
    I will not add the options to 7.2 based builds before 1.2.3 is released!



  • @ermal:

    Its a missing kernel option.
    I will not add the options to 7.2 based builds before 1.2.3 is released!

    Ok Ermal, TNX for your info.
    Can I add that option manually in boot configuration?

    Sasa



  • The best you can do isget a FreeBSD iso of 7.2 and copy /boot/kernel/ng_tcpmss.ko in /boot/kernel of pfSense and load that module for now on 7.2 2.0 pfSense.



  • Hi,

    @ssbaksa:

    @nocer:

    Hi,
    never mind, I too still have same/various issues but hey, it's only -AA. Also this seems to be fixed in 8.0-based build but sshd won't start instead.
    cheers,

    It looks to me that this is general mppd problem in 7.2 - not pfS bug.

    yup, I'm not talking'bout pfSense itself, it's more and less general FreeBSD issue indeed, I just pointed how you can go ahead and your PPPoE comes up for quick work around.

    @ermal:

    The best you can do isget a FreeBSD iso of 7.2 and copy /boot/kernel/ng_tcpmss.ko in /boot/kernel of pfSense and load that module for now on 7.2 2.0 pfSense.

    That's what I am doing for now. Put that ko in loader.conf and youre done.

    cheers,



  • TNX Ermal, TNX Nocer for your help and sugestions. I will try.



  • Many many thanx, master ermal! I tried and it works like a greasy piston! Great all that good work!



  • Installed build from 2Sept09

    Tried this:
    disable tcpmssfix in /etc/vpn/inc/interfaces.inc (line 1717) like this:
            $mpdconf .= <<<eod<br>set iface {$ondemand} on-demand
            set iface idle {$idle}
            #set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
    but i have no /etc/vpn directory
    so i tried the same change on the /etc/inc/interfaces.inc file
    –don't do that, pfsense will not work afterward, re-installed

    I am trying the following:
    copy /boot/kernel/ng_tcpmss.ko from 7.2 live cd .iso image
    paste into /boot/kernel
    i can use the Diagnostics, CommandLine interface to upload the file but i can't find the file afterward, and the interface doesn't report success/fail
    i think there is a config file i need to add ng_tcpmss.ko to as well but i can't find any reference to it now</eod<br>



  • Hi,

    I'm not quite understand what youre really looking for but assuming youre trying to force the kernel loads that ko while booting. It's really simple, not pfsense issue, very basic FreeBSD behavior, just edit loader.conf and add a line to specify the ko which you're willing to load at boot time. If I am missing your point then forget'bout it  ;D

    cheers,


Log in to reply