Pfsense won't boot unless i select option 2 from the menu (disable acpi)



  • I recently was forced to replace my old atheros card in my pfsense box because it went bad.  I ended up buying this
    http://www.newegg.com/Product/Product.aspx?Item=N82E16833166020 because there is a comment that it works with pfsense (which it does), it was cheap and it was supposed to come with a low profile bracket (which was the big thing since my pfsense box is a 2u server box with low profile cards)  It didn't come with the bracket but Rosewill was kind enough to mail me one anways….

    BUT heres the thing that is weird.....I installed the card, it booted fine...i was able to set it up, but when i tried to use the wireless i was only able to access the pfsense config page, no internet was working....i decided to try a reboot.  when it  got to "starting lan....ok" "starting wan.....ok" "starting wifi"

    it reboots...it seems to always reboot in a loop unless i choose to boot without acpi.

    I'm not REALLY that worried about acpi...but i'd like to be able to set it to AUTOMATICALLY select option 2 if for some reason the power goes out and it reboots....or if i need to reboot from another room.

    Is this possible? is there a setting in /boot/loader.conf

    thanks

    will

    hint.acpi.0.disabled="1"
    
    ```work?
    
    and if it does, is there any reason to NEED acpi for a router?
    
    edit:
    
    This DOES work…i guess i should have just tried it before posting.
    
    maybe it will help someone else though....


  • If your box runs properly without it, you can leave it disabled.



  • yes, it only runs without it.  I am not sure exactly what is happening but i do know that it will not boot with both acpi and the new pci wifi card.
    The old card worked without issue either way but now disabling it works fine so i'm happy.


Log in to reply