Crashes



  • hi ,

    I have a problem since 3 days and are unable to get it solved.  I upgraded my pfsense from 1.2 to 1.2.2, but after a few hours pfsense crashes.  I don't know the error that is appearing as the server is in a datacenter.  but a powercycle resolves it for a short while.  I don't have a kvm over ip or something connected, so i can not check the message there.  Is there maybe a log which I can consult?

    I tried 1.2.3-rc1 and the latest snapshot, but the problem exists.  The uptime before the first upgrade was 160 days.  Does anyone have a clue how I can narrow down this issue?



  • You would need to be in front of the machine.  If the box is locking up, that's a hardware issue.  If its something else like a package you have installed or state exhaustion, that's something else entirely.  You would have to be in front of the machine to chase this down.



  • Can you rule out overheating?



  • Hi,

    yeah I have planned a trip to the datacenter tomorrow morning to chase this down.  I have now a ssh session with top open, so if the machine dies, I know the state of the latest processes.

    I can rule out overheating as well as other packages.  It is not running any package, it only works as a transparent filtering bridge with nothing else like nat or vips or loadbalancer enabled.



  • Hi,

    I just went to the datacenter and had a look at the console, but there was no error.  The box wast just frozen, connecting a keyboard allowed me to turn off/on numlock and capslock.  But pfsense wasn't reacting to something else.

    I checked temperature of the box it was 27 degrees.  Which is all fine.  I have now reinstalled the box with 1.2 version to see if it locks or not.  If it doesn't lock the problem seems to me with freebsd or pfsense.

    Does anyone has things which I can check to narrow down this problem?



  • Random locking up still sounds like a thermal issue to me.
    Maybe not on the CPU but possibly in the PSU, or the voltage converters on the mainboard.
    Or even if the CPU shows within normal parameters: it's possible that you have a "hot spot" because of dust on the heatsink.



  • What was at 27 degrees?  Most boards have multiple thermal monitors, there's a world of difference between 27 degrees ambient, 27 degrees on the motherboard and 27 degrees for the CPU.



  • Hi,

    almost all temperature was the same… internal temp of 21 degrees, CPU 27 degrees.  However I have downgraded to 1.2 version and it didn't crash.  It is already running for more than 6 hours.  The 1.2.2, 1.2.3 and latest snapshot didn't make 3 hours.

    So it seems to me that there is something in freebsd 7.x that is making the machine to crash.

    It is running a supermicro pdsmi+ motherboard, the CPU is Intel(R) Core(TM)2 Duo CPU E4400  @ 2.00GHz.  The RAM has been tested with memcheck which is also fine.

    I have contacted the supplier and he is not aware of issues between freebsd and this motherboard.

    Any more ideas?



  • Check the FreeBSD mailing lists to see if anybody else has reported problems with that board.

    Check for a BIOS update.

    Try a FreeBSD 7.x live CD and see if that crashes.



  • Hi,

    The firewall is still up and running for almost 9 hours.  I have upgraded our internal firewall to the 1.2.2 version.  It is running without any crash.  The motherboard is slight different, so I am going to swap them next week, so I can investigate this more closer here at the office.

    I will check the BIOS version and try a live cd.  I already checked mailinglist etc, but the problems differ from mine.

    Now I am going on holiday for a few week.  I will put here an update when I have more information.



  • I was looking at your Supermicro's compatibility with the E4000 series CPUs and didn't find good information. I didn't even see the E4000 series listed as a compatible CPU; however Supermicro didn't say it wasn't compatible.

    I had a similar issue with my Supermicro when I used a Proc that wasn't listed as compatible but it wasn't listed as not compatible. It was unstable until I replaced it. How long have you had this board?

    One suspicion I have is that pfsense 1.2.3 is the difference in stability because of a BIOS version.



  • I just bought a Supermicro 1U barebones with the pdsmi board, which has a different north bridge than the pdsmi+ board that supports newer CPUs. I have had 1.2.3 running for 8 days without a crash. I checked the BIOS on the Supermicro site and both the pdsmi and pdsmi+ use the same one. I am running the latest BIOS. If you haven't already you might try updating the BIOS.



  • Today I remotely upgraded our primary firewall to 1.2.2.  It didn't came up anymore.  I went to the datacenter and it was just hanging in the boot sequence.  I have taken some information and will verify this tomorrow with the vendor.  As the bios version is the latest.

    So it is definitely a problem with freebsd 7.x and supermicro hardware.


Log in to reply