Internet speed drop (HTTP proxy)



  • if i turn my http proxy on,my mac internet speed drops!! to download 77 mb it took me about 41 minutes

    with the http proxy off the 77 mb only takes me 4 minutes!!

    are there some options to turn the speed up????

    settings Antivirus: HTTP proxy (havp + clamav):

    proxy mode: parend for squid
    interface: lan
    HTTP Range requests: on
    enabled ram disk
    Scan max file size: 100k



  • search the forum



  • I am having this problem too.  If I disable the proxy and restart it, sometimes this will get things running again.  I have searched on the forum and google'd but still no joy.  Does anybody have an idea what might be causing this?  And hopefully how to fix it?



  • Holy thread resurrection Batman!

    What version of pfSense are you running and what version of Squid (note - numbers, not "the latest" or anything similarly meaningless)?





  • Sorry for the resurrection…  :D But the problem description was similar to what I was experiencing.  In my case, I should have specified my specs, sorry for the confusion.  I am running pfSense 1.23, HAVP BETA
    0.90 with customized error pages, running in transparent mode.  I am not running squid at this point.  I have the HAVP ramdisk turned on and have tried various settings for the maximum size of file to scan from 5M down to 500K.  Initially download speeds are good, but after about 2 or 3 hours I will try to download something else and the speeds are a fraction of what they should be.  For example downloading from sourceforge I get download speeds of 0.2 byte/sec.  If I reboot pfsense, everything picks up for awhile and then goes south again.  For now I have uninstalled HAVP and all seems to be well again, but I would like to get it working again.  The strange thing is that bittorrent does not seem to impacted, perhaps there are enough connections that it makes up for the speed drop.  Also if I use my VPN speeds seem to be ok, which led me to find that HAVP was causing the problem.  Sorry for the late reply.



  • What if setup the maximum size of file to scan to 50..100K? Really HTML exploits not have more size.



  • I have tried lower settings to no effect.  After HAVP is running for a couple of hours download speeds just start dropping.



  • Try commenting out all the contents of your loader.conf



  • Thanks for the reply.  No joy on that solution.  Here is a copy of the contents of my loader.conf after commenting everything out.

    #autoboot_delay="3"
    #vm.kmem_size="435544320"
    #vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"

    Any other suggestions?


Log in to reply