PFSense Install Error - Return Error Code Of 1



  • Hi Guys,

    Hoping somebody can shed some light.
    I am attempt to install to a HDD(option 99) the latest version of PFSense (1.2.2).  The drive is a 160GB SataII 7200rpm Seagate drive.
    During the format / partition process i am receiving an explaining that an error has occurred with a 'return code of 1'.
    I have attempted to install this onto three different HDD, all 160gb Sata2 (various brands) and larger drives, all with the same error.
    The only drive i have actually been able to install to is a 20GB IDE drive (4year old drive).

    System Details:
    Intel Dual Core E5200
    2GB RAM
    160GB HDD

    Can anyone shed any light?

    Thank you…

    Frank



  • Have you tried one of the recent snapshot builds of pfSense? They are built on a later version of FreeBSD which seems to work better with newer hardware.



  • Hi wallabybob,

    Are you referring to the "2.0 Alpha Snapshots" available in the Downloads section of the website?
    Unfortunately, because it will be used it in a home office, i was a little concerned about it not being fully tested etc?
    Or am it stable enough to be used safely?

    Thanks for your help!

    Frank



  • No I was referring to 1.2.3 snapshots - see http://snapshots.pfsense.org/FreeBSD_RELENG_7_2/pfSense_RELENG_1_2/updates/

    There has been at least one post in the pfSense blog at http://blog.pfsense.org/ saying that for the most part 1.2.3 is suitable for production use. You can read more about pfSense 1.2.3 in the forum http://forum.pfsense.org/index.php/board,50.0.html



  • Hi Frank
    Did you sort this out?
    I have the same problem with a 56Gb drive. Driving me nuts

    cheers
    Malcom



  • Hi again.

    Found an old 30Gb drive and it installs correctly. Seems there may be a problem when installing to any reasonable sized drives?

    Also the installation procedure is quite different when the drive is changed. With the 50Gb in the machine I am prompted to set up the e/net ports before installing to the HD. With the 30Gb nothing is mentioned until installing to the HD.

    Has anyone any clues why the latest package can't handle what are now considered to be tiny drives?  Rather hard to find 30Gb drives that might still work in 12 months time…

    cheers
    Malcom



  • @Malcomm:

    I have the same problem with a 56Gb drive. Driving me nuts

    A bit more information would be useful. What version are you trying to install? On what system? How is the 56GB drive different from the 30GB drive? (e.g. SATA or IDE, drive history) Are you trying to use some form of RAID?



  • Hey Malcolmm,

    My issues was resolved by low level formatting of the drive before installing pfSense.  Once i did a LLF, it worked flawlessly on a  160GB drive.

    Frank


Log in to reply