Uplink Buffering?



  • I tried out this netalyzr app. http://n1.netalyzr.icsi.berkeley.edu/analysis/

    in my results, it posted the following

    We estimate your uplink as having 1200 msec of buffering. This is quite high, and you may experience substantial disruption to your network performance when performing interactive tasks such as web-surfing while simultaneously conducting large uploads. With such a buffer, real-time applications such as games or audio chat can work quite poorly when conducting large uploads at the same time.

    I ran it twice and got the same results both times. I do not have the traffic shaper on. Could this be a real issue? I feel that my overall internet performance has been lacking for some time.



  • We would need a lot more information.  What kind of system is this on?  What version of pfSense?  What packages do you have installed?  How is it configured?



  • What kind of system is this on?
    P4 2.4 Ghz server, 3 Gigs of ram.

    What version of pfSense?
    1.2.3-RC1

    What packages do you have installed?
    I have ntop installed, but was not running at the time that I ran the test

    How is it configured?
    We have 2 WAN ports, 1 LAN, and 1 DMZ network.
    Using some inbound nat, and virtual ip's.
    Point to Point VPN, and also PPTP.
    The test was run from the LAN port to the real WAN port (not the OPT)

    It seems that this uplink buffer is not a setting in the gui, but more of an OS / Driver issue?



  • Yeah I have the same problem, I also have an untangle network bridge in the way. I am going to try and fix this.

    Some of you guys want to try this out as well?

    Actually I just noticed that if you turn off the traffic shaper, it goes away… hmm I am confused if I want the traffic shaper anymore.

    EDIT specs:

    2.0 ghz p4
    512 ram
    I think intel nic and a rosewill nic, or two intel nics, I can't remember :P

    Untangle network bridge
    e5300
    4 gigs of ram
    one intel nic
    one onboard nic

    It's not untangle causing this though, disabling the services, or removing it out of the network completely makes no difference.
    I turned off traffic shaper for now.



  • Having the same issue, but I believe that practically it's not happening.

    1.2.3-RELEASE
    P4 2.4
    2GiB ram
    iwill based motherboard (SGS 5420)

    Upload 1.0 Mbit/sec, Download 5.0 Mbit/sec
    Uplink 1000 ms, Downlink 110 ms

    nut - running
    ntop - not running
    apache_mod_security - running
    snort - not running
    ntpd - running
    dhcpd - running
    miniupnpd - running

    Test run from LAN interface, have two VIPs and nothing important expect a port mirroring where WinPcap is always running but even without port mirroring I get the same exact results.

    Bridged modem -> pfSense >-LAN-> HP ProCurve switch -> clients


Locked