Failing big time with VLANs



  • Spent a few hours trying to get my pfSense box to talk with computers on other VLANs.

    I have a 3com 3870 Level3 switch which has 5 VLANs configured right now: VLAN1, VLAN10, VLAN20, VLAN30, and VLAN100.  Each VLAN has their own gateway on the switch.

    The pfSense server is on VLAN100 (172.30.100.20).  It cannot talk (ping) with a computer on the other vlans (Ex: VLAN1 192.168.157.26)

    I've created the VLANs and created the interfaces, so I now have OPT1, OPT2, etc.  Under these interfaces, the "Enable Optional 2 Interface" is not checked.  If I attempt to check it it requires an IP address, which I don't want to do.  I've created firwall rules for each OPT interface to pass any.

    What the heck am I doing wrong?



  • What are you trying to do? If you want pfSense to route between VLANs, it obviously needs an IP address on each VLAN subnet. If you want the switch to do routing, what's the pfSense box there for, and why would it be attached to all the VLANs?


  • Banned

    You have to have a gateway for each Vlan….. Use Virtuel IP for this. Otherwise PFsense dont know the Vlans are there, if it do not have a gateway to contact...


Log in to reply