Problems with RIP



  • Hello everyone,

    I have a network with 35 subnets which are routed though an intermediate subnet using RIP. I setup a pfSense box and put the LAN interface on the intermediate network and turned on RIP. Right away it picked up route updates but I noticed a few routes where not showing up. Here's a list of things I tried while troubleshooting.

    I ran a packet capture from the LAN interface on the fpSense box and can confirm that it is receiving all the RIP packets and routes.
    I found that some of the missing routes are coming from routers that I do have routes for. For example I have a router that advertises 192.168.2.0/24 and 192.168.3.0/24 and pfSense only adds a route for 192.168.2.0/24.
    I ran routed in debug with verbose output to a file and it shows that it received all the route updates and added them.
    I ran route -n monitor and I do see routes being added (presumably from routed) but not all of them.

    I have tried versions 1.1, 1.2 and the 2.0 alpha firmware on a few different pieces of hardware and i get the same results.

    All of the subnets basic class C blocks (i.e 192.168.1.0/24, 192.168.2.0/24, etc…) and I use ripv2 on all of my routers. I'm just stumped at this point so any help would be greatly appreciated.



  • Are you really really sure that it displays it as 192.168.2.0/24 and not as 192.168.2.0**/23**
    If it's possible the routes will be displayed in a "compact" form.



  • GruensFroeschli,
    Thank you for your response! I checked again and you are correct some routes do have /23 and /22 masks. I feel dumb overlooking that but am releived I found an answer. Thanks for your help!



  • You wouldnt belive how long i had until i noticed this when i was dealing with RIP propagated routes….. :D


Log in to reply