Ipsec vpn and Avaya voip



  • I have a pfsense 1.2.2 firewall setup with an ipsec tunnel connected to a Linsys RV042 router at the other end of the tunnel.
    To my knowledge the Linksys is Linux based but i do not know if it is using FreeS/WAN or OpenVPN.

    the vpn is confirmed up and functioning.  confirmed via a number of methods including ping and smb file transfer.
    the Avaya phone is confirmed working on local area network AND when both ends of VPN have rv042 routers.
    also confirmed to work with rv042 at one end and SonicWall at the other end.

    this is a tcpddump of the connection attempt via the VPN.

    15:39:49.970835 IP 10.2.1.200.1048 > 10.2.0.8.411: S 2568631718:2568631718(0) win 8192 <mss 0="" 1460,nop,wscale="">
    15:39:49.988161 IP 10.2.0.8.411 > 10.2.1.200.1048: R 0:0(0) ack 2568631718 win 0
    15:39:49.990607 IP 10.2.0.8 > 10.2.1.200: ICMP 10.2.0.8 tcp port 411 unreachable, length 36
    15:39:55.871573 IP 10.2.1.200.1048 > 10.2.0.8.411: S 2568631718:2568631718(0) win 8192 <mss 0="" 1460,nop,wscale="">
    15:39:55.889473 IP 10.2.0.8.411 > 10.2.1.200.1048: R 0:0(0) ack 1 win 0
    15:39:55.889514 IP 10.2.0.8 > 10.2.1.200: ICMP 10.2.0.8 tcp port 411 unreachable, length 36
    15:40:08.993479 IP 10.2.1.200.1049 > 10.2.0.8.80: S 250419840:250419840(0) win 8192 <mss 0="" 1460,nop,wscale="">
    15:40:09.012072 IP 10.2.0.8.80 > 10.2.1.200.1049: S 1315962880:1315962880(0) ack 250419841 win 4369 <mss 1024="">
    15:40:09.013103 IP 10.2.1.200.1049 > 10.2.0.8.80: . ack 1 win 8192
    15:40:09.015753 IP 10.2.1.200.1049 > 10.2.0.8.80: P 1:132(131) ack 1 win 8192
    15:40:09.034510 IP 10.2.0.8.80 > 10.2.1.200.1049: . ack 132 win 4369
    15:40:24.018826 IP 10.2.1.200.1049 > 10.2.0.8.80: F 132:132(0) ack 1 win 8192
    15:40:24.032621 IP 10.2.0.8.80 > 10.2.1.200.1049: F 1:1(0) ack 133 win 4369
    15:40:24.033942 IP 10.2.1.200.1049 > 10.2.0.8.80: . ack 2 win 8192
    15:40:27.935937 IP 10.2.1.200.1025 > 10.2.0.8.69:  24 RRQ "46xxupgrade.scr" octet
    15:40:27.948442 IP 10.2.0.8.69 > 10.2.1.200.1025:  13 ERROR ENOTFOUND "NotFound"</mss></mss></mss></mss>
    

    It is clearly evident that i am missing something.
    Any suggestions as to what that might be would be greatly appreciated.


Log in to reply