4G Microdrive on net4801



  • UPS just delivered my new 4801-50 today and I wanted to install pfSense on it to replace my old Zyxel firewall appliance.

    The embedded image works quite nicely on a 256M (I know, big enough) CF card but then I realized that I had a spare 4G Microdrive laying around.  That would allow a full install and I wouldn't have to worry about wearing the CF card with reads and writes.

    I tried both installing the embedded image with physdiskwrite (identically to the working 256M CF) and following the "Full install for WRAP embedded router" instructions but no luck, in both cases the installation to the 4G Microdrive on the PC works quite fine but the Microdrive will not boot on the 4801.

    Is there something in the pfSense install that prevents installation on a 4G Microdrive?

    Soekris' site would indicate that the hardware itself has no problem with the 4G Microdrive.



  • Not sure, how did you install the device? We installed a 2,5" hdd with full install in a soekris 4801 during the hackathon which worked just like expected, even with squid (doesn't make sense with such a slow platfrom and with few memory but it'S more or less for playing around and test). The hadd was installed in another system and moved to the soekris after installation. MAybe you have some LBA/CHS/auto issues. I have experienced that it makes a difference if you set your bios to auto or lba in some machines (the detected drive geometry in during the installer is different). Try to set your bios in the machine where you install the full cd on the microdrice to lba. Also try to check or uncheck "packet mode". I summed up some suggestions for hdd/install problems in a previous post to the mailinglist: http://www.mail-archive.com/support@pfsense.com/msg03811.html



  • I tried two ways (using 1.0 RC2):

    1. physdiskwrite on Windows XP

    physdiskwrite -u pfSense-Embedded.img

    Using the 4G Microdrive as the destination.  This works for the 256M CF.

    1. Using the LiveCD

    As described in http://wiki.pfsense.com/wikka.php?wakka=FullInstallOnWRAP

    Booted a Windows XP laptop to the pfSense using the LiveCD.  Used the 99) option install pfSense on the Microdrive, including formatting and partitioning the drive.  Bootloader installed as well.  Tried with both the original and Embedded kernel.  With and without packet mode.

    Neither way had any trouble using the 4G Microdrive (at full capacity) on the PC I used (IBM Thinkpad, couldn't find any LBA mode in the BIOS).  The pfSense is installed on the Microdrive but it doesn't boot from it and the soekris bios just says it cannot find a boot device.

    What should one do on the shell level (booting from the LiveCD) to manually install a bootloader or something on the 4G drive?  I have a few FreeBSD boxes in the basement but they've been so trouble free that I've never had to do any boot setups manually.  I will try the 2) option again with a 2G CF just to see how it goes.  Basicly I'd rather use the Microdrive as it wouldn't have any flash issues.

    Petri



  • I'm really puzzled by the problem.

    I used LiveCD on a Thinkpad laptop to install pfSense on a MicroDrive/CF-card using CF/USB-adapter.  99 from the menu, following the options to format and partition the whole drive/card for FreeBSD, bootloader installed, etc.  After installation I'd take the MD/CF and install it on a net4801-50.

    1. 2G CF-card

    The installation goes smoothly, full 2G accessible, everything looks fine.  Boot on the net4801 looks fine and the system starts up.
    ad1: 2000MB <samsung cf="" ata="" 04="" 05="" 06="">at ata0-slave PIO4 is shown before mounting root.
    Manual root fs mount's ? gives the ad1's as the valid disk boot devices

    1. 4G Microdrive

    The installation goes smoothly, full 4G accessible in the format/partitioning, everything looks fine, on the PC the CF mounts quite fine and I can change the /etc/ttys and /etc/fstab to correct information.  Installed the Microdrive to the net4801.  The BIOS will load but it cannot boot automatically, doing manually 'boot' without any parameters will start the FreeBSD kernel loading.  Kernel messages start to arrive.  At the time it should mount root fs, it fails.  Unlike with the 2G CF card, it doesn'tshow the ad1: … message for the microdrive.  Giving ? to list the valid devices doesn't show any device.

    There are no LBA settings I can find in the Thinkbad BIOS, especially not for the CF/USB-adapter.  Soekris manual mentions that it's using standard CHS mapping for smaller CF cards and LBA for >2G CF cards and microdrives.  Would it be possible that in the LiveCD FreeBSD installation it would use something else for the 4G mapping that would make the 4G CF microdrive incompatible with the Soekris-box?  Any ideas how can I make a Soekris-compatible 4G CF card on the PC?</samsung>



  • root fs

    mounting error? make sure you updated your FSTAB…im curious about the outcome of this since i have a net4801 im lookin to do same thing on....



  • Another example of a 4G microdrive that won't boot a FreeBSD 6.x image?  How long has this problem existed?



  • Yet I have a Fujitsu 4 GB microdrive that works just fine.

    Maybe it's a Seagate problem?



  • Yes, it seems to be related to the Seagate drive.  Both the 4G and 8G are affected.  I have an old IBM 1G microdrive that works.  The Seagate would be much nicer for several reasons:

    1.  2M buffer instead of, what, 8K on the IBM?

    2.  Silent operation vs. clickety click

    3.  4G vs. 1G

    4.  $29 at Outpost.com!  C'mon, a 4G microdrive for under $30?!?  The 8G is only $49.



  • I had this exact same issue except i'm not using a WRAP.  I ended up having to tether a usb->cf adapter into my unit to read the microdrive because the older CF->ide reader couldnt pick up the microdrive under freebsd.  If I were to do it again though I would avoid seagate and probably go with the fujitsu or some other solution.



  • Really?  You'd rather spend $140 on a Hitachi microdrive instead of $29 on the Seagate?  This is not a poor-quality issue with respect to the Seagate.  It USED to work, now it doesn't.  Something changed in Free BSD to bork it.  By the way, I couldn't turn up any Fujitsu microdrives at all on Google or on Fujitsu's site, so I DK what happened to their product line.  Hitachi bought out IBMs product line, of course.  I think it's just them and Seagate now.

    I just wish that bug report had been marked with something other than "non critical" on the Free BSD site.

    P.S.  I'm not using a WRAP either.


Log in to reply