Recommended Fiber NIC



  • Howdy all.  I was wondering what is the most recommended Fiber NIC for use with pfSense.  (Like how the intel is the most recommended Copper NIC)  I tried searching and didn't come up with anything.  Thanks a ton!



  • Just grab the Intel NIC with the PHY you need. The 1000base-SX gear should be widely available, while 1000base-LX is a bit more rare and I'm not sure the latest cards can do it - I do know there is a PCI-X card that can.

    It might be more cost effective, if you already have a GigE managed switch, to use a SFP transceiver on the switch and a copper NIC with a VLAN on the switch, as fibre transceivers are quite a bit cheaper (~$100) than a full fibre NIC (~$500) and copper ports are virtually free.



  • So I scored an Intel Pro 1000 PF - MultimMode LC 1000Base-SX and pfSense doesn't see it at all. :(



  • What version are you running? (Have you tried a 1.2.3 snapshot?)



  • I haven't.  I have been using the latest 1.2.2

    Ill give it a shot.



  • I tried both another machine and the RC snapshot on both machines and no dice :(



  • I notice that Intel has FreeBSD7 drivers available. How could I go about installing that driver?



  • It would probably be ugly, as I'd guess it would be em or igb, which are already in the kernel. You could (just for testing, mind you) load up a 2.0 snap based on FreeBSD 8. If it is detected there, the code will probably get mfc'd to 7.3. If you're checking the source tree, igb split from em, then they were both merged into e1000, so it gets a little confusing tracking the changes. From what I can determine, there have been several updates to support new devices since 7.2 release. You need this when? If it's very important, you could probably pay Centipede to get the sources updated to current in a stable build.



  • cant seem to get the pfsense 2.0 with bsd8, but i got the base bsd8 and ran the live cd and it didn't see my fiber nic :(
    can anyone tell me of a known good fber gigabit nic that will for sure work with pfsense?



  • @DWAyotte:

    So I scored an Intel Pro 1000 PF - MultimMode LC 1000Base-SX and pfSense doesn't see it at all. :(

    Do you mean that no driver attaches to it or do you mean that the startup doesn't it or do you mean that pciconf doesn't report it?

    There are at least two possible causes for the device being unrecognised:

    • there is no driver that recognises it
      the device is not visible on the PCI bus (perhaps it broken)

    The first option has been explored, it doesn't seem the second option has been explored.

    If your fibre card is visible of the PCI bus and is not recognised by any device driver then the FreeBSD startup will report an "unrecognised" device and the device will be visible in the output from the pciconf command. If you post the startup output (thats generally output by the dmesg command) or the output of the pciconf command I'll take a look to see if the fibre nic is visible on the PCI bus.



  • turns out my gige copper nic was the issue! the darn thing.  I replaced it and go figure, pfsense sees both NICs now, even stable 1.2.2 sees both, so I am very pleased.  pfSense wins yet again! :)


Log in to reply