Help needed with FREEswitch



  • Hi,

    I have freeswitch running on pfsense in VMWARE.

    the vmware machine is behind a firewall router, so I'm using nat and portforwarding.

    Also the freeswitch is bound to the local ip address on the freeswitch which is 192.168.0.22.

    I have successfully registered a trunk with sipgate for an 0845 number.  (it says REGED) on status.

    I have also created an extension number which I have logged onto in Eyebeam (EXT 1000).

    i have created an inbound rule in public to forward an incoming call for the sipgate 0845 … (0845xxxxxxx) which then routes to ext: 1000

    When I try and call the 0845 number using my mobile, I just get dead air for about 10 seconds then it hangs up.  No messages or anything, no ring tone.

    I've tried loads of stuff but keep failing, I want to move away from trixbox to this but I can't get it to work!!! :(

    Please help.

    Regards,

    Jon.



  • sofia status

    Name   Type                               Data State

    external profile   sip:mod_sofia@192.168.0.22:5080 RUNNING (0)
    sipgate camper hire 0845 gateway         sip:3941XXXX@sipgate.co.uk REGED
                    internal profile   sip:mod_sofia@192.168.0.22:5060 RUNNING (0)
                192.168.0.22   alias                           internal ALIASED
                internal-ipv6 profile           sip:mod_sofia@[::1]:5060 RUNNING (0)

    3 profiles 1 alias

    sofia status profile external

    =================================================================================================
    Name            external
    Domain Name      N/A
    DBName          sofia_reg_external
    Pres Hosts     
    Dialplan        XML
    Context          public
    Challenge Realm  auto_to
    RTP-IP          192.168.0.22
    Ext-RTP-IP      192.168.0.22
    SIP-IP          192.168.0.22
    Ext-SIP-IP      192.168.0.22
    URL              sip:mod_sofia@192.168.0.22:5080
    BIND-URL        sip:mod_sofia@192.168.0.22:5080
    HOLD-MUSIC      local_stream://moh
    OUTBOUND-PROXY  N/A
    CODECS          PCMU,PCMA,GSM
    TEL-EVENT        101
    DTMF-MODE        rfc2833
    CNG              13
    SESSION-TO      0
    MAX-DIALOG      0
    NOMEDIA          false
    LATE-NEG        false
    PROXY-MEDIA      false
    AGGRESSIVENAT    false
    STUN-ENABLED    true
    STUN-AUTO-DISABLE false
    CALLS-IN        0
    FAILED-CALLS-IN  0
    CALLS-OUT        0
    FAILED-CALLS-OUT 0

    Registrations:


  • Banned

    Try using 1:1 NAT instead of portforwarding…



  • Well trixbox works fine with port forwarding.

    I can't 1:1 NAT as far as I know with my router, its a Tomato router based on a linksys.  Dont think it has advanced functions like that!

    What about if I put it in a DMZ?  would that have the same effect?



  • So my understanding of your setup is that you have tomato firewall, then pfsense running in a virtual machine, and your phone registering to the LAN profile on FreeSWITCH. That setup would double NAT your SIP which can be done but complicates the setup.

    I suggest you register your phones to the internal profile which binds by default to the WAN IP of your pfsense virtual machine. Then to make it so your phones can communicate to the WAN ip from your regular local network you will need to either disable pfsense firewalling (System -> Advanced-> Disable all packet filtering.  )or set a rule for the wan ip for the SIP and RTP ports. http://doc.pfsense.org/index.php/FreeSWITCH#Firewall



  • You are correct, the virtual server pfsense is running two virtual nics and its physically and logically behind the tomato, which is at the edge of the network connected directly to our Virgin Media cable modem.

    Because WAN and LAN on my pfsense are both internal I have put them on the same subnet, is that wrong?

    192.168.0.22 LAN, 192.168.0.23 WAN.

    I have already disabled the firewall in advanced options.

    My freeswitch seems to bind to the LAN automatically?  How do I get it to bind to WAN?

    I'll have another mooch about it tonight. :)  Cheers for the replies.

    Cheers,

    Jonathan.



  • @bodleytunes:

    Because WAN and LAN on my pfsense are both internal I have put them on the same subnet, is that wrong?

    192.168.0.22 LAN, 192.168.0.23 WAN.

    I have already disabled the firewall in advanced options.

    Since you have the firewall turned off and both LAN and WAN are in the local area network it probably doesn't matter which one they bind to. You would want register to the internal profile. You would want the external profile to use the same IP as the internal profile. You can tell which IP the profile binds to by taking a look at 'Status' page.

    @bodleytunes:

    My freeswitch seems to bind to the LAN automatically?  How do I get it to bind to WAN?

    http://doc.pfsense.org/index.php/FreeSWITCH#IP_address_or_Domain



  • It binds to the internal 192.168.0.22

    My softphone eyebeam registers fine with extension 1000 (registers to 192.168.0.22), i can get voicemail and call myself etc.

    However outgoing and incoming calls dont work.

    Im trying to get incoming working first, just get dead air when i call.  There is no sign of any extension ringing and i dont get a ring tone on my mobile phone that im testing it from, just nothing!

    Looks like the freeswitch does register with sipgate.  and if i go into sipgate control panel and look at devices, it shows "sofia" registered device so its there.?

    its definitely ports or incoming routing or something.


Log in to reply