[Solved] vpn client cannot be accessed by lan



  • Hey guys,

    I setup shrew soft vpn as per the document on this site. i can connect remotely and access all of my computers in every method i've tried.

    the problem i'm seeing is that my computers cannot make new connections to the vpn client. let's say i'm at home behind my pfsense box and my client is connected somewhere on the internet. i want to vnc to that client… i cannot do this. i can't ping it or anything else.

    i'm not seeing any drops in the real-time firewall log. any ideas?

    Solution is here:
    http://forum.pfsense.org/index.php/topic,18406.msg94704.html#msg94704



  • Are you trying to go out throught the tunnel to the VPN client?  Have you added routes back to the VPN client from the internal network?

    I was testing the VPN connectivity and it worked like a charm.  I have both OPENVPN and IPSEC clients setup and installed.

    I will admit I could ping the VPN client and connect from the pfsense firewall.  I never tested going the other way that hard.  I did not have any trouble but never push anything out.

    RC



  • could you give me some advise on what the rule should look like?

    the internal side is 192.168.1.0/24, the vpn client is 192.168.2.0/24



  • i'm sorry - this is an IPsec vpn question, not openvpn. if someone could move it to that forum it would be great…


Log in to reply