When proxy fails to throw up authentication request



  • Hi there,
    Totally new to pfsense so apologies ahead of time for nonsense questions.
    Have tried searching the forum and web on this but not got anywhere so am trying here.

    Our org recently switched from MS IAS to pfsense.

    Some applications seem to refuse to throw up an authenication interface when going through a proxy. With IAS I used a neat little application called cntlm which handled this for me. I would run cntlm on client machines as a service. It runs as a local proxy on localhost:whatever_port_you_assign_it_to. It has an ini file which has user's credentials including an MD5 hashed user password for the IAS proxy. So this cntlm proxy would sit between the client and the site proxy and deliver the user credentials up to every request from the site proxy server - no need for the client to enter credentials. It solved the problem of some apps not serving an interface for users to enter proxy credentials.

    However now we have swtiched to pfsense I have lost that ability as cntlm doesn't seem to work with pfsense.

    Here's a for instance:
    I use a website which uses a Java app to upload files. It works fine on internet explorer. However when I try it in Firefox it eventually times out with the message "The server or proxy not found". I'm assuming it's because it probably is finding the proxy server but doesn't know how to prompt to ask for credentials.

    Any help on this would be appreciated thanks.


Log in to reply