Dnsmasq not covering multiple interfaces

  • I just migrated my company from Endian Firewall System (EFS) over to pfSense and am VERY IMPRESSED by this superb piece of software though quite perplexed on many fronts and still trying to figure it out as I muddle through networking without any vision whatsoever.

    I have 3 interfaces on the firewall itself:
    LAN on dc1
    WAN on bfe0
    OPT1 (SERVER) dc0

    Eventually I'd like to set the WAN to run VLAN on our T1 connection and DSL, but am just using the T1 for now to keep it simple as I work out some of the other issues such as lack of DNS resolution on our SERVER side.

    I have DHCP Server enabled on the LAN side and things work great and the DNS server of (which is pfSense) responds, but when it comes to the SERVER side pfSense responds on the WebGUI as well as SSH but will not answer any DNS requests. I've even opened up the entire firewall for the server side, tried adding rules for DNS, tried enabling DHCP on the SERVER side, and cannot for the life of me get Dnsmasq to answer.

    thank you for taking the time to read this, and here's hoping I can learn from all of you and become more proficient at pfSense.

Log in to reply