Error adding package



  • Can someone help me fix this?
    I cannot install mc

    pkg_add -r mc

    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.1-release/Latest/mc.tbz… Done.
    pkg_add: package 'mc-4.6.1_3' or its older version already installed

    mc

    /libexec/ld-elf.so.1: Shared object "libintl.so.6" not found, required by "mc"
    When ive tryed to add for the first time it worked and ive used before.



  • pkg_delete -r mc
    pkg_add -r mc



  • cd /var/db/pkg && pkg_delete -r ls | grep mc



  • pkg_add -r gettext



  • (This post is about 8 months after the previous message!! But it's mainly for anyone who hits the same problem…)

    Experimenting with the Developers build (Apr, 2007), and trying to install MC. Same message as quoted above. GETTEXT now uses LIBINTL.SO.8. MC still seems to rely on LIBINTL.SO.6.

    Quickie soln:
    cd /usr/local/lib
    ln -s libintl.so.8 libintl.so.6

    I've seen warnings that this linking might break other apps, but, I don't see how this might happen. (I'm a newbie to lots of this stuff). In any case, one could run "rm libintl.so.6" after the MC session, to remove the link.

    - Mike



  • cd /var/db/pkg && pkg_delete -r ls | grep mc

    In the course of experimenting with getting MC running, I ran the above command, but ended it with "GREP M" (instead of "GREP MC"!)

    I may have deleted other M* packages!

    I would greatly appreciate if anyone could post a list of all the "M*" entries in /var/db/pkg (if any!), in the standard Developers edition.

    Thank you.
      - Mike


Log in to reply