WAN setup and disconnection.



  • _Forgive me, for I am a newbie.

    I'm working with a Soekris 4801, and a Atheros card. I have 1 WAN connected to my modem, 1 LAN connected to a computer, and the WLAN is connected to two laptops. My problem is, I cannot access the internet/modem. The router uses the default 192.168.1.1, and the modem uses 192.168.1.254.

    Here is what I've been doing: I assign the three ports, setup the WLAN to bridge to the LAN (to keep the same subnet). The LAN stays as is. The WAN has a static public IP address, but tried it on DHCP figuring it's asking for the IP of the router as assigned by the modem. Tried Static, thinking the same, and putting gateway as the router's IP (192.168.1.254).

    To be honest, I'm a dope with this, and am trying to learn as I go, but I'm not sure what I'm doing wrong or what I've missed. I DO get WLAN connection, but again no internet with LAN or WLAN._



  • Wan interface: 192.168.1.1 netmask: 255.255.255.0 (/24) gateway: 192.168.1.254
    Lan interface:192.168.2.1 netmask 255.255.255.0 gateway "blank"

    Clients: 192.168.2.x netmask 255.255.255.0 gateway 192.168.2.1

    nat rule: nat 192.168.2.0/24 out on wan.

    Bridge WLAN (opt) to LAN.

    Rules:
    allow any from lan
    allow any from WLAN

    That is the key elements you need to get it working.



  • Bah! No, still not communicating with the modem. I have the modem set to assign any connection (LAN wise) to 192.168.1.1, and it's stuck at 192.168.1.254, so that has to be configured correctly. Nat, bridging, and firewall rules are as you say, and the LAN is working off 192.168.2.X with 192.168.2.1 being the router.

    Still, no connection to the modem. Can't even access it's webGUI through the router. So… I'm still confused. =/



  • Bump?

    Modem's IP is 192.168.1.254, sets all clients hooked to it to have an IP of 192.168.1.1 (By setting the DHCP range from 192.168.1.1 to 192.168.1.1, because the damn modem doesn't want to do anything BUT DHCP). Router's IP is 192.168.2.1, and sers all clients hooked to it to have an IP of 192.168.2.x. Firewall Rules allow everything, NAT is as suggested above. WLAN is bridged to LAN. WAN is set to Static with it's IP being 192.168.1.1 and gateway being 192.168.1.254.

    Can't access the modem on 192.168.1.1 or 192.168.1.254. Can't ping, and can't get an internet connection.

    I'm completely at lost as to what I'm not doing right.


Locked