Vigor 120 ADSL Modem + PPPoE in the UK?



  • Hi,

    Has anyone tried the Vigor 120 ADSL modem with pfSense in the UK, on a coventional UK (PPPoA) ADSL line?

    At present, I use an ADSL router in front of pfSense, but I'd like to eliminate the router, and do everything from pfSense with a view to a simple dual-WAN setup, as my ISP (http://aaisp.net ) offers bonding of multiple ADSL lines.

    Most UK ADSL connections use PPPoA, but the Vigor 120 modem offers PPPoE -> PPPoA conversion in order to allow your host device to control the ADSL connection itself.

    This sounds interesting for pfSense… Has anyone tried it here in the UK on a normal (non-LLU) BT line?

    Thanks!

    • Martin


  • Well, I'm not in the UK and don't have a Vigor120.  But I did research that model when looking for a replacement for my Vigor2600Plus, including the PPPoE -> PPPoA conversion.  That mode allegedly works when PPPoE pass-through is selected and you use a different PPPoE client behind the Vigor, such as pfSense.

    The Vigor2600Plus also has PPPoE pass-through mode but I had problems getting that mode to work with any PPPoE client, including pfSense, as explained at length here: http://forum.pfsense.org/index.php/topic,18234.0.html

    In the end, I decided against the Vigor120 because Draytek support staff "assured" me that there was no problem with Vigor2600Plus in PPPoE pass-through mode despite the detailed testing that I had documented and made available to them. On those grounds, I concluded that they probably had not made changes to the way the PPPoE pass-through mode works and therefore it was/is likely to suffer from the same problem.

    That may not be the case - it may work just fine - but it seems like a risk not worth taking.



  • give me until tommorrow. i use draytek 100's but they normally go into drayteks. they work with adsl and adsl2+ in the uk.
    i have a brand new alix but have installed pfsense v2 onto it and it does indeed have bugs. so i'm going to switch it back to the latest stable version and i'll let you know. this will be going on an o2 line which doesn't use a password and a vci of 101 but still use the pppoe>pppoa



  • Thanks for the info, much appreciated.



  • ooops….
    i was working on it this morning but have just been called out for a server issue. got a family function as well at tonight. sunday afternoon will be the time now. sorry.



  • well, i'm up and running with an alix2d13 and a draytek 100. running snort with a couple of rules and it appears ok.
    because I'm on O2 (bethere) adsl2+ annexm, their setup is:
    IP LLC Bridged
    VPI 0
    VCI 101
    MPOA enabled
    modulation annexm

    there is no password required so pppoe will not work with the above. Set the pfsense wan to static or dhcp.
    that's it!
    i can give you an idea of speeds in a day or so as my speeds look slow from a news server that i normally get full whack on. first thing in the morning will give me a better idea.



  • Sounds good.  Think I'll get a Vigor 120, test it and report back.

    Thanks!

    • Martin.


  • ok…..
    the only issue i have with this modem is that it's on O2/bethere. due to the way this ISP works, the 100 will not get a greater speed than 6.5mb whereas before i can get 19mb/2.5mb.
    this is an issue with this particular modem as detailed here:
    http://www.draytek.co.uk/support/kb_vigor_inp.html



  • and…....
    just had a look at your original post and what you were using it for. current version of pfsense will only allow 1 x pppoe interface. v2 supports multiple pppoe afaik.
    my setup would work as there is no logon and i use static instead of pppoe.



  • Thanks for the update.  I will do some testing in a lab setup first.

    Cheers,

    • Martin


  • switched it out with the O2 lll (thomson) box which was supplied. dropped that into bridge mode and i'm back on full whack again.
    can't vouch for them on any other adsl2+ as o2 & bethere use their own setups. they do work well on adsl max though as long as you have a good line ie not too long.



  • Thanks again, appreciate the tweaking required to test.

    • Martin.

Log in to reply