Squid + Squidguard: Not working in Time-Based ACL



  • Hello.. I set up under Times then made two ACLs. BTW, I have only one source IP since after pfsense where one router lies.

    QUESTION: How would I allow time-based shifting of ACL? or.. is this kind of set-up realistic?

    Hope to hear from you guys in here..THanks in advance.



  • Hello xerxes

    I just got my pfsense installed yesterday I think I set it up the same way you are asking.
    I have setup web browsing for 8am - 10pm only.

    I did this in a few simple steps.

    Installed Squid and content filter

    Under Proxy Server
    Auth settings Tab  –-> Authentication method: local
    Local Users Tab ---> create user account

    Under Proxy Filter
    Time Tab

    Name: time
    Values: Time type Days   Date or Date range Time range
              Weekly            All        Left blank                08:00-20:00  (this is the time you want access granted)

    Description: Time

    ACL Tab
    Name: time
    Source IP adresses and domains: 'username'  (be sure to have the single quotes)
    Time: (select time or whatever you called your setting)
    Destination: Set your filter optiosn here

    Other options are optional.

    Then save and be sure to apply the settings afterwards.  Then you should be good to go.  I just got this setup and it works like a charm.



  • @xerxes:

    Hello.. I set up under Times then made two ACLs. BTW, I have only one source IP since after pfsense where one router lies.

    QUESTION: How would I allow time-based shifting of ACL? or.. is this kind of set-up realistic?

    Hope to hear from you guys in here..THanks in advance.

    Here howto:


Log in to reply