Snort rule download…



  • Hello:
    I am running pfSense 1.2.2 and today installed Snort 2.8.4.1 pkg v. 1.4. I set the performance to ac-bnfa, chose to use the WAN interface, entered my Oinkmaster code, saved, and tried to check out my rules. The problem is, there aren't any. There are also no categories. When I click on the rules tab, I receive this error at the top of the screen:
    Warning: sort() expects parameter 1 to be array, null given in /usr/local/www/snort_rules.php on line 101 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/snort_rules.php:101) in /usr/local/www/guiconfig.inc on line 35 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/snort_rules.php:101) in /usr/local/www/guiconfig.inc on line 36 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/snort_rules.php:101) in /usr/local/www/guiconfig.inc on line 37 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/snort_rules.php:101) in /usr/local/www/guiconfig.inc on line 38 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/snort_rules.php:101) in /usr/local/www/guiconfig.inc on line 39

    I have tried for several hours to update the rules via the "Update Rules" tab, but I continue to get the message that I can only update the rules every 15 minutes. Reinstalling the Snort package has not fixed this issue, either.

    Has anyone run into this? Also, I have downloaded the Snort rules from their site. How would I install them manually into PFSense?

    Thanks,
    Stephen



  • OK, it's working now. I just needed to reboot the pfSense box and the rules downloaded.


Log in to reply