Squid 0.4 beta on RC2



  • I've encountered some problems in installing the Squid package (0.4 Beta) on pSense 1.0 RC2.

    After install, the following message repeats at the bottom of the page:

    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49

    At times, it also says line 505.

    Looking at the source code, the error happens at certain times in the install process:

    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 505
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 505
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 505
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 505
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    Warning: in_array(): Wrong datatype for second argument in /usr/local/pkg/squid.inc on line 49
    
    

    Squid does appear to be working, but it can be hard to tell. Any known issues or workarounds for those errors?



  • Sounds like leftover squid settings from a previous installation.

    You need to:

    1. Deinstall squid
    2. edit /cf/conf/config.xml and remove <squid>…</squid>
        NOTE: the dots means everything in between
    3. rm /tmp/config.cache
    4. Reinstall squid



  • @sullrich:

    Sounds like leftover squid settings from a previous installation.

    I had the exact same error on a completely virgin installation of RC2 and Squid 0.4



  • uninstall squid
    upgrade to the latest version of rc2 i beleve its rc2g now
    install squid again



  • @jeroen234:

    uninstall squid
    upgrade to the latest version of rc2 i beleve its rc2g now
    install squid again

    I uninstalled squid, cleaned up cache and config.xml,  upgraded up to f (didn't find any g?) and reinstalled. Same errors I'm afraid.


Locked