FTP and NAT, again…



  • Hello everyone. I've been working on that problem for hours, lurking the whole web but still without any solution.

    First of all, yes, I read the sticky posts and set up everything as mentionned. The problem is…it doesn't work.

    I'm trying to set up a FTP server behind my multiwan. So we have WAN, OPT1, OPT2 and LAN, with load balancing and failover.
    First :

    • I tried to disable the FTP helper on ALL interfaces ;
    • I set up vsftpd to use passive port range 42020 to 42099 and to echo the WAN public IP (normally it's a dynamic IP that I resolve using pasv_addr_enable but for testing purposes I just entered the IP) ;
    • I forwarded port 21 and range 42020-42099, TCP to my local IP address ;
    • For testing purposes again I created firewall rules that allow every traffic from/to this address ;
    • iptables / selinux are disabled on the server ;
    • I tried to log on the server using the WAN public IP.

    Guess what...failure. The connexion went fairly good, but I got a timeout during FEAT command. Then, I was unable to connect at all for a long time. If I let my FTP client try to reconnect automatically, it ends up with a totally frozen pfSense box that I need to reboot manually.

    Second :

    • I tried to enable FTP Helper on LAN ;
    • I only forwarded port 21 here.

    Failure again.

    Any help would be much appreciated.



  • Nobody knows ? Really looks like routing goes perfectly well but something crashes after that.



  • Are you comfortable with doing packets dump?



  • I'm not an expert but I think I would survive  :)



  • Then go ahead! do dumps and post them here.


Log in to reply