Forward the original header…..


  • Banned

    Greetings!

    I have an FTP server running and the log says that every connection attempt comes from the pfsense box, and not the original IP adress.

    How can I change that behavior??? So I can monitor behavior on the FTP server….

    This is NOT specific to port 21...so it is not related to FTP alone.



  • Are you using the FTP-helper?
    If yes:
    Disable the helper.
    You need to set up your FTP server to use a fixed passive port range and then forward this range additionally.

    What exactly do you mean that this is not port 21 specific?
    Do you see the exact same thing with logs on your webserver or whatever you're running on this machine?
    Are you source-NATing?


Log in to reply