I Can't get internet connection from other side of BGP route.
-
Ok so today I was doing some testing in my NSX Lab. I have 2x CSR-1000v's the issue was I can only get 1000kbs out of the outside interfaces. So after some reading, I decided to give Pfsense a shot. I just need the throughput to make sure that my config is working. So what I am asking is, what would be the equivalent of this config on Pfsense?
!
router bgp 6500
bgp router-id 10.10.10.1
bgp log-neighbor-changes
redistribute connected
neighbor 192.168.43.5 remote-as 443
neighbor 192.168.43.6 remote-as 443
neighbor 192.168.0.5 remote-as 100
neighbor 192.168.0.6 remote-as 100
!
interface GigabitEthernet1
ip nat outside
ip address 192.168.1.2 255.255.255.0
no shut
!
interface GigabitEthernet2.43
encapsulation dot1Q 443
ip address 192.168.43.2 255.255.255.0
ip nat inside
standby 43 ip 192.168.43.1
cdp enable
!
interface GigabitEthernet2.100
encapsulation dot1Q 100
ip address 192.168.0.2 255.255.255.0
ip nat inside
standby 1 ip 192.168.0.1
cdp enable
!
ip nat inside source list OUTSIDE interface GigabitEthernet1 overload
!
ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip route 192.168.1.0 255.255.255.0 GigabitEthernet2.100 192.168.0.4 #Route VIP to BGP NET this extends internet to the BGP segments.
!
ip route 192.168.1.0 255.255.255.0 GigabitEthernet2.43 192.168.43.4 #Route VIP to BGP NET this extends internet to the BGP segments.
!
ip access-list standard OUTSIDE
permit 192.168.0.0 0.0.0.255
permit 192.168.43.0 0.0.0.255
permit 10.4.43.0 0.0.0.255 #BGP Segment
permit 13.20.14.0 0.0.0.255 #BGP Segment
deny any"By the way BGP is working fine on the pfsense downstream just not back upstream.."