PPPoE with Static IP's



  • I have looked (here, google, the moon)…I cannot find an answer. I also didn't see a fitting forum for this question.

    Situation: I got a new Biz DSL line with ATT. I got a /29 as well.

    I put my Motorola 2210 into bridged mode, set PFsense up for PPPoE and it authenticates just fine and works.

    Here is the problem: There is no where to specify a static IP (and subsequent gateway) on the WAN interface when you put it into PPPoE Mode.
    ATT is archaic enough to dish out Dynamic IP's ONLY, making you specify your statics if you want to use them.
    Every other device that I have that supports PPPoE can specify a manual IP address when using PPPoE (even the xbox360!).

    I would just have the modem do the authentication, but it doesn't support that...it's becomes a dumb bridge when you put it in that mode.

    I'd really like to continue to use pfsense, what am I missing? or what can I tear up to make this work?

    I've loaded 1.2, 1.2.2, & 1.2.3-RC1 on my embedded platform (alix) and they all look the same.



  • let me clarify:

    The only thing I need to do, it set an IP on the WAN interface. Nothing fancy is needed to make this work.


  • Rebel Alliance Developer Netgate

    I run an ISP and we do PPPoE and for our static customers the addresses are assigned with PPPoE and are tied to their username. Are you sure nothing like that is going on?

    I've not heard of anyone using PPPoE and then requiring a static IP set on top of that.

    Or perhaps you do not need to use PPPoE at all when you are set for static?



  • @jimp:

    I run an ISP and we do PPPoE and for our static customers the addresses are assigned with PPPoE and are tied to their username. Are you sure nothing like that is going on?

    I've not heard of anyone using PPPoE and then requiring a static IP set on top of that.

    Or perhaps you do not need to use PPPoE at all when you are set for static?

    I'm 100% positive that is the way it's done, and they require PPPoE Auth to jump on the network.

    Ma Bell (AT&T) is very archaic in the way they do things, yet spin enough BS that they convince themselves they are doing it right.

    I've done some light digging into pfsense to no avail, but I'm sure there is someone who can tell me how to manually set a static in a few seconds. This should definitely be an option from the GUI.


  • Rebel Alliance Developer Netgate

    Actually the network that out PPPoE rides over to customers is AT&T and locally here it works the same way for their customers, though it may vary by region.

    I checked a soho Linksys router and it also had no static IP options for PPPoE, but I don't have any other equipment handy that does PPPoE.



  • I have a Zonet ZSR 0104CP Ill look at tomorrow but I believe it also has no provisions for static on pppoe…



  • @jimp:

    Actually the network that out PPPoE rides over to customers is AT&T and locally here it works the same way for their customers, though it may vary by region.

    I'm in GA in the old Bellsouth territory, so that probably makes a difference. I remember when I had Qwest in Seattle they used PPPoE but routed the statics to you like a proper ISP should.

    I called 'em just to verify I wasn't going crazy…and I'm not.


Log in to reply