SquidGuard users unable to browse sites



  • Hello guys. Good afternnon. After Installing squidguard and uploading blacklist, users unable to browse websites. Anyone? What could be the problem? I've re-install the package. I have squid running and works well. I even disable the blacklist but still users are unable to browse sites..But if I disable the squidGuard works normal.. All i want is to use the ACL and block proxies. My redirect_children is set to 9.

    jigp
    1.2.2



  • How you configure SG?



  • Thanks for the reply :)

    First, squid runs pretty good. Then I install SG, I didnt enable yet the SG.

    I first upload urlblacklist (/var/tmp/bigblacklist.tar.gz - upload the list here) hit save then i hit/check Enable then hit Apply and hit Save @ General Setting..

    At Default, I check "Not to allow IP addresses in URL".. Default destination> I set Default access [all] into "deny", Proxy is "deny" and the rest just "–---"..

    At ACL, i add unrestricted IP <source ip="" adresses="" and="" domains=""> .. In Destination ruleset (click) I deny Proxy again and deny "Default access all" and Check Not to allow IP addresses in URL..

    Then I configure squidGuard.conf change the redirect_children 3 to redirect_children 12.. Back to General setting hit "Apply" then "Save"..

    I then go back to Squid hit "Save"

    Restart pfsense..and i cannot browse.. But there is IM..

    jigp
    1.2.2 squid+SG



  • Keywords:
    @jigpe:

    At Default, …I set Default access [all] into "deny", .
    At ACL, … In Destination ruleset (click) I deny Proxy again and deny "Default access all" and

    You are deny all but nothing allow. Set "Default access all" as allow.



  • Thanks for the reply :)

    It works now but problem is browsing is slow. If i watch youtube.com it takes 11 minutes to load the video. But if i disable the squidGuard it backs to normal and youtube plays like loading 2 to 3 minutes. I have traffic shaper+squid+SG.. Tnx

    jigp
    1.2.2 traffic shaper+squid+SG


Log in to reply