Switching to https leaves pfsense WebIF dead



  • When switching the 8.0 BSD pfSense-2.0-ALPHA-ALPHA-20090916-0501 to https the Webif isn't anymore reacheable. Logfiles in /var/log/ have all the same size: 65535 and are filled with funny chars.
    Even deleting this files and creating them new with touch they have the same size after reboot. So no Logs available.

    Resetting the Webif to http is without change.

    Only thing which I saw when pressing the save-button on the admin-access-page was a warning in the TCP-Port-entry. While realizing this it was too late to copy it out, because the page disappeared… So I couldn't copy the content. This warning appeared when I hitted the save-button, it was empty before! I didn't want to change the port.

    lighttpd -t

    2009-09-16 22:51:48: (server.c.578) No configuration available. Try using -f option.

    Found out that in the lighty-WebConfigurator.conf is a wrong entry:
    server.port ARRAY
    has to be changed to the Port used (80 or 443)

    Then started the lighttpd and in the Port-field on the Admin-Access contains this:
    Warning: htmlspecialchars() expects parameter 1 to be string, array given in /usr/local/www/system_advanced_admin.php on line 264



  • Can't say for 2.0, but I have had to reboot a few of my boxes in the past to complete the switch to https.  Have you tried that and did it help?  Also, make sure that you're not running squid on the same port as the WebUI, I know that one has gotten many people in the past, but doesn't sound like it's your problem.



  • I did various restarts with no effect. There seems to be maybe a typo somewhere in one script, because I have warnings inside of the fields like in TCP-Port or other ones. It seems to be only in System - Advanced. I played around with settings in system.inc, but everytime when lighty-webconfigurator.conf is written I have web-Port = ARRAY and lighttpd doesn't start till I change ARRAY to "80" to get lighttpd on again.

    At last my skills in understanding the scripts is too low to "repair" this.


Log in to reply