Squid+HAVP works but not Lightsquid?



  • Hello,

    i have now it so that squid and Havp work with transparent mode.

    But the Problem now is that in the Lightsquid log all the Websites have the same IP like Pfsense (192.168.1.1), what do i wrong?  ???
    Forwarded IP is checked  :'(





  • I guess that's one downside to this config. I didn't have lightsquid enabled..just Squid/Squidguard/Havp…This config seems to be the only way I can get it working for all 3 together. I guess lightsquid has to be the monkey wrench. I used to have lightsquid enabled, but never had the need to look at it much, so I uninstalled it.



  • yes this works great with squid+havp+Squidguard but guard is in the moment disabled, because i want to test why lightsquid not work with havp.

    though there was the option "Enable Forwarded IP" so that havp gives squid the original IP's and lightsquid can see them. We have some users surf on erotic sites and want then to know which pc was it.
    Maybe there is only a litte small option so that squid has the real IPs, that was the perfect way Squid+HAVP+SquidGuard+++LightSquid  ;D



  • Ive tried multiple ways of setting this up and this seems to work the best…getting all 3 working right. In Squidguard I have porn sites blocked, so I generally don't have to worry much about something slipping by. Why don't you just block porn altogether if you don't want sites accessed? And if something slips by in lightsquid that you don't like, you can block that also for the time being.



  • @ColdFusion

    How much RAM do you have on your HAVP? and how much users do you have on that box? (just curious of how much HD eats by the HAVP with squid)



  • I have 2 boxes 1 with 1 gig ram and the other 2 gig ram…Havp is set for 1/4 memory(check box)......5-8 users only and 3-5% Hard drive space used.
    Squid is set 100MB memory(1 gig box) and 384MB (2 gig box).



  • tested now again all way with lightsquid, but now i think there is no way with lightsquid+havp  :-\



  • I'm running Squid, SquidGuard, and HAVP and LightSquid works fine for me. Set your HAVP to run as a parent and that'll fix the problem. See below for my settings:






  • Well, I'll be damned….now she works....tried this way multiple time on 2 boxes and couldn't get squidguard to work this way. maybe something has changed since then, but anyway thanks for chiming in.



  • Hey,

    thanks very much that is really nice, and works perfect on my test machine. want now test it next week on our server with first 80people  :)



  • has anyone with HAVP + squid+ squidguard install  see havp block any virus malware or anything I have it install and it never once  stop/block anything but the eicar virus test. it does not seem to be scanning because I tested it by going to some infected sites
    on the test system and all virus, and nasty go it not one was stop by Havp  but ESET and KAV caught them. I restarted test system
    to get back to original state and tried again same results.

    also can these work with HAVP
    ;
    rsync://rsync.sanesecurity.net/sanesecurity/junk.ndb
    rsync://rsync.sanesecurity.net/sanesecurity/phish.ndb
    rsync://rsync.sanesecurity.net/sanesecurity/rogue.hdb
    rsync://rsync.sanesecurity.net/sanesecurity/scam.ndb



  • i tested it only with the eicar test virus and this works. but will test it now with any other virus (hope i find one ;-) )



  • i think it works havp founds all

    http://www.testvirus.de/de/testvirus.html

    is there any way how i can modify the havp found template?



  • so works perfect

    first step 60 users HP DL160 Xeon CPU 3040 @ 1.86GHz - 2GB RAM - 160GB HDD

    15% RAM in use
    1% Disk usage
    1% CPU usage



  • I dont understand whats going on but I have HavP  + Squid+ squidguard work nothing has change but HavP + Squid+ squidguard stop working its not filtering or blocking anything but the service is showing as started. is anyone one else seeing this.



  • working ok here….



  • I have to restart HAVP and Squid upon every reboot, even when it tells me the services are running. I wish this issue could be fixed because it's troublesome to have to restart services all the time.



  • have no problems with 1.2.2 and the services, squid has stops sometimes with version 1.2.0RC.

    @Tox whats with a reinstall of the packages? All Services runs?

    seems some more people have problems

    http://forum.pfsense.org/index.php/topic,19550.0.html



  • Possible look from console error messages while pfSense started? Interested packages resync stage.
    Also any syslog errors exists ?


Log in to reply