Getting NUT working



  • Hi.

    For a few weeks I've been trying to get NUT working. It just seems to not want to. It may just be a silly thing than I'm not seeing.

    pfSense is installed on a Dell Poweredge 1850 and my UPS is an APC Smart-UPS 1500VA with USB and Serial connection. Since I don't have a serial cable available, I'm using USB connection.

    When I plug in the USB cable to the server, some text telling that the APC smart ups has been connected to port blabla.. so connection should'nt be an issue.

    I configure NUT like seen below:

    UPS Monitoring Local UPS
    Local UPS Name myups
    Local UPS Model Smart-UPS USB
    If generic or cable specified in parenthesis you need to select the appropriate option below.
    Local UPS Port auto (usb only)
    Local UPS Generic Type blank
    Local UPS Cable Type blank
    Power Down Instead of Halt unchecked
    Local Remote Access Address
    (ex: 192.168.1.0/24) 192.168.1.0/24
    Local Remote Access User testuser
    Local Remote Acces Password *****

    The status reports ERROR! NUT is enabled, however the service is not running!

    Please, could anyone assist me with this? If you want to, you can PM me and we might sort out some remote desktop or an other way to connect.

    Kind Regards,
    Excizted.



  • Edit /usr/local/pkg/nut.xml

    change all instances of newhidups to usbhid-ups

    restart nut by hitting the Save button to restart Nut.

    Just an FYI…using USB causes stale data periodically in the logs. You can try tweaking some settings if you search the forum for nut stale data.
    Currently, though stale data often re-appears. My temp fix ATM is using a Cron job every 15-30 minutes to restart Nut.

    Hope this helps.



  • I seem to be having exactly the trouble you're describing – regularly stale data. Can you please tell me where is the command that I need to point to with a crontab command to get NUT restarted regularly?



  • /usr/local/etc/rc.d/nut.sh start


Log in to reply