Bug: Wireless Atheros 5212 chip - ath0 mtu 2290



  • Bug: Atheros chip is forced to mtu 2290?

    Been running pfsense 1.2.2 without any problems. My setup looks like this:
    WAN
    LAN
    WIFI

    WIFI ssid; qwe
    WIFI in AP mode
    Bridge LAN-WIFI
    Firewall rule to allow all traffic from WIFI to LAN (using dhcp from LAN interface)

    Today I tried to port my setup to the 2.0 Alpha. I used this image (booted from cd, made simple install):
    pfSense-2.0-ALPHA-ALPHA-20090919-0102.iso
    I only added WAN and LAN interfaces during install.

    GUI:
    When I try to add my wireless card it seemse like everything is okey. And i prossede to make the bridge. Everything seems fine (No errors from the gui atleast)

    But I cant find the wireless AP when I try to connect with my laptop. Sometimes a ssid:linksys with full strength comes along, but dissapear if I refresh the list (pretty sure this is the pfsense wifi card, prob a bug in the device driver or when the interface is beeing brought back after reconfig?).

    Status -> Interfaces:
    WIFI interface (ath0)
    Status no carrier
    MAC address 00:13:f7:3d:17:52
    Media autoselect
    In/out packets 0/0 (0 bytes/0 bytes)
    In/out packets (pass) 0/0 (0 bytes/0 bytes)
    In/out packets (block) 0/0 (0 bytes/0 bytes)
    In/out errors 1643/0
    Collisions 0
    Bridge (bridge0) learning

    When bridging LAN and OPT1 i get this message in console:
    :bridge0: Ethernet address: 0a:26:b1:96:8b:69
    bridge0: illegal mtu for ath0

    And ifconfig show me that the mtu us 2290 (which is strange?)

    ifconfig

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
           ether 00:13:f7:3d:17:52
           media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
           status: no carrier
    xl0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
           options=9 <rxcsum,vlan_mtu>ether 00:04:75:d1:b2:59
           inet 10.0.0.1 netmask 0xffffff00 broadcast 10.0.0.255
           inet6 fe80::204:75ff:fed1:b259%xl0 prefixlen 64 scopeid 0x2
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    xl1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=9 <rxcsum,vlan_mtu>ether 00:04:75:d0:2f:fd
           inet6 fe80::204:75ff:fed0:2ffd%xl1 prefixlen 64 scopeid 0x3
           inet 85.221.107.137 netmask 0xfffffc00 broadcast 85.221.107.255
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    bfe0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
           options=8 <vlan_mtu>ether 00:0d:56:6c:7c:da
           media: Ethernet autoselect (none)
           status: no carrier
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
           pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33176
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
           options=3 <rxcsum,txcsum>inet6 ::1 prefixlen 128
           inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9
           inet 127.0.0.1 netmask 0xff000000
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           ether 0a:26:b1:9b:8b:b9
           id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
           maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
           root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
           member: xl0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 2 priority 128 path cost 200000

    ifconfig ath0

    ath0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 2290
           ether 00:13:f7:3d:17:52
           media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
           status: no carrier

    ifconfig ath0 set mtu 1500

    ifconfig: set: bad value

    ifconfig ath0 set mtu 1492

    ifconfig: set: bad value

    ifconfig ath0 set mtu 2290

    ifconfig: set: bad value

    ifconfig ath0 set mtu 1000

    ifconfig: set: bad value

    ifconfig ath0 set mtu 1234

    ifconfig: set: bad value

    ifconfig ath0 set mtu 1300

    ifconfig: set: bad value

    ifconfig ath0

    ath0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 2290
           ether 00:13:f7:3d:17:52
           media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
           status: no carrier

    phpSysInfo:
    Canonical Hostname pfSense.local
    Listening IP 10.0.0.1
    Kernel Version FreeBSD 8.0-RC1 #0 Sat Sep 19 00:44
    Distro Name  FreeBSD
    Uptime 50 minutes
    Current Users 2
    Load Averages 0.16 0.11 0.09

    Model Intel(R) Celeron(R) CPU 2.60GHz
    CPU Speed 2.59 GHz
    PCI Devices - atapci0: Intel ICH4 UDMA100 controller

    • ath0: Atheros 5212
    • bfe0: Broadcom BCM4401 Fast Ethernet
    • ehci0: Intel 82801DB/L/M (ICH4) USB 2.0 controller
    • isab0: PCI-ISA bridge
    • pcib1: ACPI PCI-PCI bridge
    • uhci0: Intel 82801DB (ICH4) USB controller USB-A
    • uhci1: Intel 82801DB (ICH4) USB controller USB-B
    • uhci2: Intel 82801DB (ICH4) USB controller USB-C
    • vgapci0: VGA-compatible display
    • xl0: 3Com 3c905C-TX Fast Etherlink XL
    • xl1: 3Com 3c980C Fast Etherlink XL

    IDE Devices - acd0: SAMSUNG CD-R/RW SW-252S/R901

    • ad0: WDC WD1200BB-00CAA0 16.06V16 (Capacity: 117.27 GB)

    One last thing that I have noticed:
    GUI -> Interfaces -> WIFI:
    Standard: (its blank, cant choose anything! In 1.2.2 it was 802.11b, 802.11g and 802.11g Turbo)
    Channel: Auto (this is the only available option, in 1.2.2 I have 12 options, and "Channel 6 - Turbo".

    Not sure what to make of this, and Im changing back to 1.2.2 for now.

    –----------------------------------------------
    From 1.2.2, up and running without problems

    ifconfig

    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
           ether 00:13:f7:3d:17:52
           inet6 fe80::213:f7ff:fe3d:1752%ath0 prefixlen 64 scopeid 0x1
           media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
           ssid g2 channel 1 (2412 Mhz 11g) bssid 00:13:f7:3d:17:52
           authmode WPA2/802.11i privacy MIXED deftxkey 3 TKIP 2:128-bit
           TKIP 3:128-bit txpower 31.5 scanvalid 60 bgscan bgscanintvl 300
           bgscanidle 250 roam:rssi11g 7 roam:rate11g 5 protmode OFF burst
           -apbridge dtimperiod 1
    xl0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
           options=9 <rxcsum,vlan_mtu>ether 00:04:75:d1:b2:59
           inet6 fe80::204:75ff:fed1:b259%xl0 prefixlen 64 scopeid 0x2
           inet 10.0.0.1 netmask 0xffffff00 broadcast 10.0.0.255
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    xl1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=9 <rxcsum,vlan_mtu>ether 00:04:75:d0:2f:fd
           inet6 fe80::204:75ff:fed0:2ffd%xl1 prefixlen 64 scopeid 0x3
           inet 85.221.107.137 netmask 0xfffffc00 broadcast 85.221.107.255
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    bfe0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
           options=8 <vlan_mtu>ether 00:0d:56:6c:7c:da
           media: Ethernet autoselect (none)
           status: no carrier
    plip0: flags=108810 <pointopoint,simplex,multicast,needsgiant>metric 0 mtu 1500
    pflog0: flags=100 <promisc>metric 0 mtu 33204
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
           inet6 ::1 prefixlen 128
           inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
           inet 127.0.0.1 netmask 0xff000000
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
           pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           ether 0e:86:a7:0f:86:c3
           id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
           maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
           root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
           member: xl0 flags=143 <learning,discover,autoedge,autoptp>member: ath0 flags=143 <learning,discover,autoedge,autoptp>phpSysInfo:
    Canonical Hostname pfSense.local
    Listening IP 10.0.0.1
    Kernel Version FreeBSD 7.0-RELEASE-p8 #0 Thu Jan 8 22:07
    Distro Name FreeBSD
    Uptime 20 minutes
    Current Users 2
    Load Averages 0.12 0.09 0.16

    Processors 1
    Model Intel(R) Celeron(R) CPU 2.60GHz
    CPU Speed 2.59 GHz
    PCI Devices

    • atapci0: Intel ICH4 UDMA100 controller
    • ath0: Atheros 5212
    • bfe0: Broadcom BCM4401 Fast Ethernet
    • ehci0: Intel 82801DB/L/M (ICH4) USB 2.0 controller
    • isab0: PCI-ISA bridge
    • pcib1: ACPI PCI-PCI bridge
    • uhci0: Intel 82801DB (ICH4) USB controller USB-A
    • uhci1: Intel 82801DB (ICH4) USB controller USB-B
    • uhci2: Intel 82801DB (ICH4) USB controller USB-C
    • vgapci0: VGA-compatible display
    • xl0: 3Com 3c905C-TX Fast Etherlink XL
    • xl1: 3Com 3c980C Fast Etherlink XL
      IDE Devices
    • acd0: SAMSUNG CD-R/RW SW-252S/R901
    • ad0: WDC WD1200BB-00CAA0 16.06V16 (Capacity: 117.27 GB)</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></up,running></up,loopback,running,multicast></promisc></pointopoint,simplex,multicast,needsgiant></vlan_mtu></broadcast,simplex,multicast></full-duplex></rxcsum,vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,vlan_mtu></up,broadcast,running,promisc,simplex,multicast></hostap></up,broadcast,running,promisc,simplex,multicast></broadcast,simplex,multicast></broadcast,simplex,multicast></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></rxcsum,txcsum></up,loopback,running,multicast></promisc></up,running></pointopoint,simplex,multicast></vlan_mtu></broadcast,simplex,multicast></full-duplex></rxcsum,vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,vlan_mtu></up,broadcast,running,promisc,simplex,multicast></up,broadcast,running,simplex,multicast>



  • Rebel Alliance Developer Netgate

    Wireless is sort of crazy in 2.0 right now anyhow, it's about to be overhauled once things get going on FreeBSD 8.0.

    This same bug was fixed in 1.2.3, not sure if the fix was also done on 2.0 or what.


  • Rebel Alliance Developer Netgate

    Here is the other thread where the bug was found/fixed in 1.2.3:

    http://forum.pfsense.org/index.php/topic,15468.msg87493.html#msg87493



  • The bug is not present in: pfSense-Full-Update-1.2.3-20090919-1549.tgz



  • That was fixed in 1.2.3 but not in 2.0 since the wireless in 2.0 will be going through a major overhaul to support FreeBSD 8.


Log in to reply