Howto and why



  • Hi everybody!

    I use pfSense 1.0 RC 2.
    I configure PPPoE service. And connencting w2k client. Error code 612, the port is disconnected.  I tested the w2k client another pppoe server and to operate.

    And test the pfSense to the ovislink rs1200 sec gw, but don't to operate.

    My config:
    Interface OPT1
    Interface ip address: 192.168.144.1/24  (and another test the dchp client)

    PPPoE service conf
    Interface: OPT1
    Subnet:/24
    Server Address: 192.168.144.254
    Remote Address Range: 192.168.144.0

    Not used Radius

    Users tab
    username: teszt
    Password: teszt
    Ip address: 192.168.144.18

    Firewall rules:
    OPT1 Interface
    default accept, the default tab config

    VPN PPPoE Interface
    default accept, the default tab config

    log:
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] device: CLOSE event in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] pausing 6 seconds before open
    Aug 26 15:33:32 mpd: [pppoe0] device: OPEN event in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] LCP: Close event
    Aug 26 15:33:32 mpd: [pppoe0] link: CLOSE event
    Aug 26 15:33:32 mpd: [pppoe0] bundle: CLOSE event in state OPENED
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: LayerFinish
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: state change Starting –> Initial
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: Close event
    Aug 26 15:33:32 mpd: [pppoe0] closing link "pppoe0"…
    Aug 26 15:33:32 mpd: [pppoe0] LCP: LayerFinish
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Starting –> Initial
    Aug 26 15:33:32 mpd: [pppoe0] LCP: Close event
    Aug 26 15:33:32 mpd: [pppoe0] LCP: LayerStart
    Aug 26 15:33:32 mpd: [pppoe0] LCP: phase shift ESTABLISH –> DEAD
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Stopped –> Starting
    Aug 26 15:33:32 mpd: [pppoe0] LCP: Down event
    Aug 26 15:33:32 mpd: [pppoe0] link: DOWN event
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] device: DOWN event in state CLOSING
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state CLOSING
    Aug 26 15:33:32 mpd: [pppoe0] device: CLOSE event in state UP
    Aug 26 15:33:32 mpd: [pppoe0] LCP: LayerFinish
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Ack-Sent –> Stopped
    Aug 26 15:33:32 mpd: [pppoe0] LCP: parameter negotiation failed
    Aug 26 15:33:32 mpd: [pppoe0] LCP: not converging
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #20 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #20
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #19 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #19
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #18 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #18
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #17 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #17
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #16 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #16
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #15 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #15
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #14 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #14
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #13 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #13
    Aug 26 15:33:32 mpd: MRU 1400
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Nak #12 link 0 (Ack-Sent)
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Req-Sent –> Ack-Sent
    Aug 26 15:33:32 mpd: ENDPOINTDISC [LOCAL] ef f8 97 93 9b f5 49 28 94 e1 6a a2 f7 ab 0d bf 00 00 00 00
    Aug 26 15:33:32 mpd: MAGICNUM 1be543bd
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigAck #1
    Aug 26 15:33:32 mpd: ENDPOINTDISC [LOCAL] ef f8 97 93 9b f5 49 28 94 e1 6a a2 f7 ab 0d bf 00 00 00 00
    Aug 26 15:33:32 mpd: MAGICNUM 1be543bd
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Request #1 link 0 (Req-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1492
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #12
    Aug 26 15:33:32 mpd: PROTOCOMP
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Reject #11 link 0 (Req-Sent)
    Aug 26 15:33:32 mpd: MP MRRU 1614
    Aug 26 15:33:32 mpd: CALLBACK
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigRej #0
    Aug 26 15:33:32 mpd: ENDPOINTDISC [LOCAL] ef f8 97 93 9b f5 49 28 94 e1 6a a2 f7 ab 0d bf 00 00 00 00
    Aug 26 15:33:32 mpd: MP MRRU 1614
    Aug 26 15:33:32 mpd: Not supported
    Aug 26 15:33:32 mpd: CALLBACK
    Aug 26 15:33:32 mpd: MAGICNUM 1be543bd
    Aug 26 15:33:32 mpd: [pppoe0] LCP: rec'd Configure Request #0 link 0 (Req-Sent)
    Aug 26 15:33:32 mpd: AUTHPROTO CHAP MD5
    Aug 26 15:33:32 mpd: MAGICNUM cb2adacc
    Aug 26 15:33:32 mpd: MRU 1492
    Aug 26 15:33:32 mpd: PROTOCOMP
    Aug 26 15:33:32 mpd: [pppoe0] LCP: SendConfigReq #11
    Aug 26 15:33:32 mpd: [pppoe0] LCP: phase shift DEAD –> ESTABLISH
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Starting –> Req-Sent
    Aug 26 15:33:32 mpd: [pppoe0] LCP: Up event
    Aug 26 15:33:32 mpd: [pppoe0] link: origination is remote
    Aug 26 15:33:32 mpd: [pppoe0] link: UP event
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state UP
    Aug 26 15:33:32 mpd: [pppoe0] device: UP event in state OPENING
    Aug 26 15:33:32 mpd: [pppoe0] PPPoE connection successful
    Aug 26 15:33:32 mpd: [pppoe0] device is now in state OPENING
    Aug 26 15:33:32 mpd: [pppoe0] PppoeOpen() on incoming call
    Aug 26 15:33:32 mpd: [pppoe0] device: OPEN event in state DOWN
    Aug 26 15:33:32 mpd: [pppoe0] LCP: LayerStart
    Aug 26 15:33:32 mpd: [pppoe0] LCP: state change Initial –> Starting
    Aug 26 15:33:32 mpd: [pppoe0] LCP: Open event
    Aug 26 15:33:32 mpd: [pppoe0] link: OPEN event
    Aug 26 15:33:32 mpd: [pppoe0] opening link "pppoe0"…
    Aug 26 15:33:32 mpd: [pppoe0] bundle: OPEN event in state CLOSED
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: LayerStart
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: state change Initial –> Starting
    Aug 26 15:33:32 mpd: [pppoe0] IPCP: Open event
    Aug 26 15:33:32 mpd: [pppoe0] PPPoE response sent
    Aug 26 15:33:32 mpd: [pppoe0] Accepting PPPoE connection
    Aug 26 15:33:32 mpd: Incoming PPPoE connection request via xl0: for service "*" from 00:04:75:fd:e7:c5

    ########
    Why don't documentation to the function?????????
    How to configuration the PPPoE server ??????
    ########

    Otherwise the great tool the pfSense!!!


    Sorry My Litle English



  • this is a windows issue i have lots of experiance  with windows clients and pppoe so you have to believe this some clients will work fine and some don't
    you really need to use a good pppoe dialer on any version of windows.
    dr tcp will help you lower the mtu so you client does not have so many problems
    i would also suggest you disable your ccp extension son the pppoe server on pfsense. i can't remember the config paramators for mpd daemon but the docs for it are on sourceforge

    also another issue we see a lot is the defaults for windows pppoe auth are wrong for our setup and need to be manually adjusted.

    my two cents worth i have a bit of development time at the moment so should be around on the forums for the next few days if you have other questions


Locked