Squid (61) Connection refused error?



  • Hello!

    I'm running Squid and SquidGuard and everything has been working perfectly until yesterday. Out of the blue, we started getting a (61) Connection refused error to http://accountreview.com/citrix/metaframe. I was told this was working as of last friday and no changes have been made to the firewall. I've since put the site and IP in every white list I could find, and it is still blocking it. If I turn off SquidGuard, I can get to the site. I have to be missing something, but I just don't know what. Does anyone have any idea what it could be?

    Here is the full error I get:

    While trying to retrieve the URL: http://accountreview.com/Citrix/MetaFrame

    The following error was encountered:

    •Connection to 69.7.231.14 Failed
    The system returned:

    (61) Connection refusedThe remote host or network may be down. Please try the request again.

    Thanks in advance!



  • Can you access othere sites besides that site? Tell us your squidguard configuration.



  • Yes, at the time we could access all other sites but that one. At the time I posted this, I had tried restarting the squid guard service but only resolved the issue with it off. Once I restarted squid, the problem was resolved. It's been about a week or so and the issue hasn't came back.



  • This issue came back today. I tried to just restart the services, but once I stopped squid it would not start back up… so I had to reboot. What could be causing this?



  • It seems as if this is probably my issue:
    http://forum.pfsense.org/index.php/topic,9737.0.html

    I have not found a way to disable pinger in squid, maybe someone on here knows how?


Log in to reply