[SOLVED] Geometry BS



  • Long story short I have this one machine that FreeBSD seems to hate! (not the same machine as my other thread incase anyone was wondering, that machine is up and running!)

    Months ago I tried to install FreeBSD 7 on it and got a geometry error when formatting disk, someone in ##freebsd on freenode ended up recommending me a geometry that worked, got the drive formatted, partitioned and FreeBSD installed.

    Only downfall was it only actually booted 1 in 2 or 3 tries, the times is failed it spit out some geometry error I can't remember. So I went with Arch Linux and it worked great, acted as my LAN router for months.

    Recently I have come accross pfSense and really want to give it a go but I am running into this geometry stuff again during the install.

    My first install went as follows

    http://imgur.com/GV0oS
    http://imgur.com/VqtuN
    http://imgur.com/4O4mY
    http://imgur.com/ePifr

    Seemed to install fine but would not boot. So I try again and get the following:

    http://imgur.com/IYgAe
    http://imgur.com/2uhbf
    http://imgur.com/E7dCo

    I really have no idea what is going on, can anyone help? I am using pfSense-1.2.3-20090922-0023.iso.gz on a m7ncg 400 with a Hitachi Deskstar 7k80 80gb IDE

    Edit:

    I slaved the HDD into my desktop machine, created a VM with it as its disk and installed pfSense on it that way. Put the HDD back in the machine I wanted it on and booted from it without a problem, strange how I had to do that…

    More here for people having same problem: http://forums.freebsd.org/showthread.php?p=42431


Log in to reply