Sleeping thread causes panic

  • After installing the pfSense-2.0-ALPHA-ALPHA-20090922-0454.iso (FreeBSD 8 ) i noticed that after a while without doing anything (even didn't change anything except IP of LAN-interface) the box hangs with the following message on screen:

    Sleeping thread (tid 64080; pid 45292) owns a non-sleepable lock
    panic: sleeping thread
    cpuid = 1

    Runs on a Dell 1750 with 2x XEON, 2GB mem.

    Same error I had with older releases too

  • The same problem of mine.
    Testing today versions.

    older Intel celeron hardware

  • Can you find out which process is that pid?

  • I did a fresh install with pfSense-2.0-ALPHA-ALPHA-20090923-0921 (8.0 Freebsd), activated ssh and changed IP. After several hours of "not touching the system" i looked at the screen, nothing. Menu is on, no error. When I tried to get access via ssh it panic-ed again. I shot a foto of the screen because it was too much info to write down. Other pid, so i think it varies. The pid-number even is different.

    Hope its to read. Bad quality…

    Now after half an hour it paniced again, other pid. It panic-ed when I tried to get access via ssh. Other pid again. Next time i try to see if the logs show anything. Is there any "more useful" thing I can do to help you finding the problem?

Log in to reply