Load balancing not working, but works with only 1 WAN plugged in



  • This is driving me nuts here, I have tried various configurations, but they either don't work or keep things the same.

    When both of my WANs are online then internal browser requests begin to intermittently (mostly) time out.

    If either of the WANs (but only one) are online, then the performance is solid from the web browser.

    I suspect this is DNS related since it doesn't seem to impair IP address based traffic.

    I've set things up mostly following the guide http://doc.pfsense.org/index.php/MultiWanVersion1.2 but have not set up a DMZ.

    Some of my settings:

    Also, on the DNS Forwarding screen, DNS forwarding is enabled, and "Register DHCP leases in DNS forwarder" is checked.

    Anyone have any ideas?



  • I would be very interested to see the solution to this. I have the exact same problems. Alson trace route from the gui works great. From any LAN segment, it times out. I bought new hardware and installed pfSense specifically for it's load balancing feature. Now I'm where I was with my pix, one connection.  I asked around in the IRC and the same issues surfaced.



  • Traigo - Is this a known issue then?  Or just something that only happens to the occasional installation?



  • I was hoping it was something with the setup not configured correctly and not the load balancing feature. I haven't been able to determine either way yet.



  • From reading your previous post, I think your problem is a little different from mine.  I don't need to change any of my settings to get my connection working, just unplug the cable for either WAN or OPT1.  As long as only one network connection is present, it works fine with my existing settings.

    But with both WAN connections plugged in, it just doesn't seem to work.



  • No, I'm having the exact same problem. My thinking is that there is something that is either not configured correctly, or is not working properly that prevents the load balancing from working properly when both connections are online.



  • You might try to log all of your firewall rules since the routing is based on those and possibly create a rule or two so that you can see where the traffic goes.



  • Please try changing your monitor ip addresses to well known public dns servers' ip address such as 4.2.2.1 or opendns.  I was having same problem as mentioned by the OP.  Then I changed my monitor ip addresses to opendns's ip.



  • For the below rules .remove the below two rules. Just have the one above . And sunny is right , put Open DNS servers as your monitor IP instead of using your ISP Servers. in place of DNS  also you can use the same Open DNS servers. and check

    I think this will resolve your issue.


Log in to reply